Neutrino: USB Stick

testuser1234
Registrierte Benutzer
Registrierte Benutzer
Beiträge: 50
Registriert: Sa 29. Okt 2011, 19:54
Hat sich bedankt: 0
Danksagung erhalten: 0

Re: Neutrino: USB Stick

#16

Beitrag von testuser1234 »

Hier ist die neue Bootarg File.

ethaddr=00:1D:EC:xx:yy:zz
filesize=FC0000
fileaddr=A4000000
bootcmd=bootm a0040000
board=stb7100ref_27
autoload=n
bootargs=console=ttyAS0,115200 root=/dev/mtdblock3 mem=36m bigphysarea=1280 coprocessor_mem=2m@0x04000000,2m@0x04200000
ipaddr=192.168.xxx.111
gatewayip=192.168.xxx.1
netmask=255.255.255.0
serverip=192.168.xxx.23
front=0
backlower=0
backupper=0
rootdelay=10
bootmenutimeout=3
bootdesc_0=----Flash----
bootdesc_9=----MINI-1----
bootdesc_8=----MINI-2----
bootdesc_7=----MINI-3----
bootcmd_0=run bootargs_0; bootm a0040000
bootargs_0=set bootargs console=ttyAS0,115200 root=/dev/mtdblock2 ip=${ipaddr}:${serverip}:${gatewayip}:${netmask}:kathrein:eth0:off mem=64m coprocessor_mem=4m@0x10000000,4m@0x10400000 rootdelay=0 nwhwconf=device:eth0,hwaddr:${ethaddr} init=/bin/devinit
bootcmd_9=usb reset;ext2load usb 0:2 a5000000 /boot/uImage;run bootargs_9;bootm a5000000
bootcmd_8=usb reset;ext2load usb 0:3 a5000000 /boot/uImage;run bootargs_8;bootm a5000000
bootcmd_7=usb reset;ext2load usb 0:4 a5000000 /boot/uImage;run bootargs_7;bootm a5000000
bootargs_9=set bootargs console=ttyAS0,115200 root=/dev/sdb2 rw ip=${ipaddr}:${serverip}:${gatewayip}:${netmask}:kathrein:eth0:off mem=64m coprocessor_mem=4m@0x10000000,4m@0x10400000 rootdelay=${rootdelay} usb-storage.usbwait123=${front}:${backupper}:${backlower} nwhwconf=device:eth0,hwaddr:${ethaddr} init=/bin/devinit
bootargs_8=set bootargs console=ttyAS0,115200 root=/dev/sdb3 rw ip=${ipaddr}:${serverip}:${gatewayip}:${netmask}:kathrein:eth0:off mem=64m coprocessor_mem=4m@0x10000000,4m@0x10400000 rootdelay=${rootdelay} usb-storage.usbwait123=${front}:${backupper}:${backlower} nwhwconf=device:eth0,hwaddr:${ethaddr} init=/bin/devinit
bootargs_7=set bootargs console=ttyAS0,115200 root=/dev/sdb4 rw ip=${ipaddr}:${serverip}:${gatewayip}:${netmask}:kathrein:eth0:off mem=64m coprocessor_mem=4m@0x10000000,4m@0x10400000 rootdelay=${rootdelay} usb-storage.usbwait123=${front}:${backupper}:${backlower} nwhwconf=device:eth0,hwaddr:${ethaddr} init=/bin/devinit
bootdesc_default=0

Leider immer noch das gleiche Problem. Ich habe den Bootvorgang protokolliert:



maxiU-Boot 1.3.1 (May 19 2010 - 23:05:16) - by SoLaLa

DRAM: 64 MB
Flash: 16 MB
In: serial
Out: serial
Err: serial
selected Image to start: ----Flash----
selected Image to start: Kathrein UFS910
selected Image to start: ----MINI-1----
Hit any key to stop autoboot: 1 0
USB0 Super Top M6116018VE15
USB1 Reader 62
USB2 SMI Corporation 2010111200009966
loading from usb 0:2
## Booting image at a5000000 ...
Bad Magic Number
STB7100-REF>

Was nun?

Nochmals meine Konfig:
USB vorne: Mini Stick
USB hinten unten: Eine 2.5" Festplatte
USB hinten oben: smargo

Eins verstehe ich noch nicht. ISt dieser Eintrag richtig?
bootcmd_9=usb reset;ext2load usb 0:2 a5000000 /boot/uImage;run bootargs_9;bootm a5000000
Muss das nicht usb 1:2 oder 2:2 heissen?



__________________Update ________________________
ext2load usb 0:2 geaendert in
ext2load usb 1:2 und
rootdelay=6 gesetzt.
Jetzt laeuft!
__________________Update ________________________

Benutzeravatar
BPanther
Administrator
Administrator
Beiträge: 11199
Registriert: Do 11. Jan 2007, 00:06
Wohnort: Berlin
Hat sich bedankt: 272 Mal
Danksagung erhalten: 409 Mal
Kontaktdaten:

Re: Neutrino: USB Stick

#17

Beitrag von BPanther »

Nun, HIER sind ja die Parameter erklärt und es würde heißen, daß der erste Wert den Du ändern willst, eine Art Wartezeit oder der USB-Anschluß ist. Beides kann ich allerdings nicht so bestätigen. Selbst bei mehreren Sticks oder wechsel der USB-Anschlüsse ist es bei mir immer 0:PARTNUMMER gewesen, lediglich bei BA war es etwas anders.

Das "Bad Magic" allerdings was das UBoot meldet weist auf ein Problem mit dem Stick hin. Entweder ist es wirklich der falsche der da versucht wird zu benutzen, dann kannst Du mit dem ersten Wert durchaus mal rumprobieren oder der Stick selbst wurde nicht richtig erkannt vom Format her (Partition).

Ich würde vorschlagen, erstmal alles rauszuziehen, was erstmal nicht benötigt wird, also am besten erstmal nur den Stick selbst drin zu lassen. Bootet die Box dann, kann man dem dann immernoch genauer auf den Grund gehen und weiter testen, woran es liegt.


EDIT: Aja, bei Dir also doch 1:PARTNUMMER. Liegt vielleicht am usbwait - das benutze ich hier nicht. Habe nur HDD (intern, SATA) und Stick (manchmal auch 2).
EDIT2: Nimm doch bei stm24 statt dem rootdelay=X einfach rootwait - erspart das rumexperimentieren mit den Werten, da das Kernel das dann selbst bestimmt.
MfG BPanther
KEIN SUPPORT PER PN -> Bitte das Forum nutzen und das Wiki lesen.


Bild Bild
Thx udog für das Bild.
TV: Sony Bravia KDL-46HX755, Sony Bravia KDL-40W4500 (old)
Boxen mit NMP und Unicable2 (Jess): 7x UFS910 (128MB), UFS912, 2x UFS913, AV700, AV7000, AV7500 (DVB-S/C/T), Edision Argus Pingulux,
Vizyon820HD, 3x AX 4K HD51 (DVB-S/SX/C/T/T2), VU+DUO, VU+Solo4K (DVB-S/SX (FBC)/C/T/T2 (DUAL)), VU+Duo4K (DVB-S/SX (FBC)/C (FBC)),
VU+Ultimo4K (DVB-S/SX (FBC)/C (DUAL)), VU+Uno4KSE (DVB-S/SX (FBC)/C (FBC)), 2xVU+Zero4K (DVB-S/SX)

Antworten

Zurück zu „UFS910 - USB“