Re: Media One

Benutzeravatar
dryeye
Registrierte Benutzer
Registrierte Benutzer
Beiträge: 43
Registriert: Sa 23. Nov 2019, 19:17
Hat sich bedankt: 47 Mal
Danksagung erhalten: 15 Mal

Re: PluginGuru

#16

Beitrag von dryeye »

habe es auch mal probiert ...ich kann hier auch keinen film starten.
im log ist leider nichts hilfreiches erkennbar...

Code: Alles auswählen

key: 006c value 1, translate: 006c -cursor down-
ShowText '05.02 02:00 Mankells Wallander - Tod in den Sternen'
key: 006c value 0, translate: 006c -cursor down-
key: 0160 value 1, translate: 0160 -ok-
key: 018e value 1, translate: 018e -red button-
mfg dryeye
mfg dryeye
Benutzeravatar
Frankenstone
Co-Admin
Co-Admin
Beiträge: 2876
Registriert: Mo 4. Jul 2011, 21:19
Wohnort: Pott
Hat sich bedankt: 210 Mal
Danksagung erhalten: 142 Mal
Kontaktdaten:

Re: PluginGuru

#17

Beitrag von Frankenstone »

Ich kann hier auch keinen Film starten mit dem Media One Plugin.
KEIN SUPPORT PER PN !
Fragen über PN zum DDT oder meinem GIT werden kommentarlos gelöscht !
Bitte das Forum benutzen und in das Wiki schauen.


1* Mut@nt HD51 4K Ultra HD Linux Receiver mit 2 x DVB-S2X Si 2166D
1* AX HD51 4K Ultra HD Linux Receiver mit 2 x DVB-S2 AVL 6211
1* BRE2ZE4K DVB-S2 AVL 6211
4* UFS 913
2* UFS910 ausser betrieb ( Rentner :mrgreen: )
1* Banana Pi Pro
1* Inverto Unicable2 32-fach Quattro Multischalter IDLU-UST110-CUO1O-32P Raster 60 MHz 2*16
1* Toshiba TL 868 TV
1* LG TV
Benutzeravatar
Don de Deckelwech
Registrierte Benutzer
Registrierte Benutzer
Beiträge: 55
Registriert: Sa 3. Feb 2018, 13:20
Hat sich bedankt: 6 Mal
Danksagung erhalten: 23 Mal

Re: PluginGuru

#18

Beitrag von Don de Deckelwech »

Hi,
also bei mir läuft es, sowohl auf Tank als auch auf HD51, jeweils NI-Image.

Ciao,
DdD.
Benutzeravatar
BPanther
Administrator
Administrator
Beiträge: 11760
Registriert: Do 11. Jan 2007, 00:06
Wohnort: Berlin
Hat sich bedankt: 351 Mal
Danksagung erhalten: 578 Mal
Kontaktdaten:

Re: PluginGuru

#19

Beitrag von BPanther »

Hier klappts auch problemlos auf Ultimo4K (ARM) und DM8000 (MIPS) probiert.
MfG BPanther
KEIN SUPPORT PER PN -> Bitte das Forum nutzen und das Wiki lesen.


Bild Bild
Thx udog für das Bild.
TV: Sony Bravia KDL-46HX755
Boxen mit NMP und Unicable2 (Jess):
SH4: 7x UFS910 (1W, 128MB), 1x UFS910 (14W, 64MB), 1x UFS912, 2x UFS913, 1x AV700, 1x AV7000, 1x AV7500 (DVB-S/C/T), 1x Edision Argus Pingulux, 1x Vizyon820HD
MIPS: 1x VU+DUO, 1x DM8000
ARM: 3x AX 4K HD51 (DVB-S/SX/C/T/T2), 1x VU+Solo4K (DVB-S/SX (FBC)/C/T/T2 (DUAL)), 1x VU+Duo4K (DVB-S/SX (FBC)/C (FBC)),
ARM: 1x VU+Duo4KSE (DVB-S/SX (FBC)/C (FBC)), 1x VU+Ultimo4K (DVB-S/SX (FBC)/C (DUAL)), 1x VU+Uno4KSE (DVB-S/SX (FBC)/C (FBC)), 2x VU+Zero4K (DVB-S/SX)
Benutzeravatar
Frankenstone
Co-Admin
Co-Admin
Beiträge: 2876
Registriert: Mo 4. Jul 2011, 21:19
Wohnort: Pott
Hat sich bedankt: 210 Mal
Danksagung erhalten: 142 Mal
Kontaktdaten:

Re: PluginGuru

#20

Beitrag von Frankenstone »

Fehler entdeckt in Zeile 853

Code: Alles auswählen

if selected == RC.play and vPlay and UrlVideo then
Dies muss ersetzt werden mit

Code: Alles auswählen

if selected == RC.red and vPlay and UrlVideo then
mit dem Roten Knopf.
KEIN SUPPORT PER PN !
Fragen über PN zum DDT oder meinem GIT werden kommentarlos gelöscht !
Bitte das Forum benutzen und in das Wiki schauen.


1* Mut@nt HD51 4K Ultra HD Linux Receiver mit 2 x DVB-S2X Si 2166D
1* AX HD51 4K Ultra HD Linux Receiver mit 2 x DVB-S2 AVL 6211
1* BRE2ZE4K DVB-S2 AVL 6211
4* UFS 913
2* UFS910 ausser betrieb ( Rentner :mrgreen: )
1* Banana Pi Pro
1* Inverto Unicable2 32-fach Quattro Multischalter IDLU-UST110-CUO1O-32P Raster 60 MHz 2*16
1* Toshiba TL 868 TV
1* LG TV
Benutzeravatar
Frankenstone
Co-Admin
Co-Admin
Beiträge: 2876
Registriert: Mo 4. Jul 2011, 21:19
Wohnort: Pott
Hat sich bedankt: 210 Mal
Danksagung erhalten: 142 Mal
Kontaktdaten:

Re: PluginGuru

#21

Beitrag von Frankenstone »

Fehler entdeckt in Zeile 853

Code: Alles auswählen

if selected == RC.play and vPlay and UrlVideo then
Dies muss ersetzt werden mit

Code: Alles auswählen

if selected == RC.red and vPlay and UrlVideo then
mit dem Roten Knopf.

Ich habe es mal neu gepackt.
Funktioniert wieder und alle 3 Dateien nach plugins legen, denn ich hasse es wenn alles so zerstreut wird.
media_one.tar.gz
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
Folgende Benutzer bedankten sich beim Autor Frankenstone für den Beitrag (Insgesamt 4):
dryeye (Sa 6. Feb 2021, 16:32) • udog (Sa 6. Feb 2021, 16:39) • blacky49 (Sa 6. Feb 2021, 17:09) • thc09 (Sa 6. Feb 2021, 18:38)
Bewertung: 30.77%
KEIN SUPPORT PER PN !
Fragen über PN zum DDT oder meinem GIT werden kommentarlos gelöscht !
Bitte das Forum benutzen und in das Wiki schauen.


1* Mut@nt HD51 4K Ultra HD Linux Receiver mit 2 x DVB-S2X Si 2166D
1* AX HD51 4K Ultra HD Linux Receiver mit 2 x DVB-S2 AVL 6211
1* BRE2ZE4K DVB-S2 AVL 6211
4* UFS 913
2* UFS910 ausser betrieb ( Rentner :mrgreen: )
1* Banana Pi Pro
1* Inverto Unicable2 32-fach Quattro Multischalter IDLU-UST110-CUO1O-32P Raster 60 MHz 2*16
1* Toshiba TL 868 TV
1* LG TV
Benutzeravatar
dryeye
Registrierte Benutzer
Registrierte Benutzer
Beiträge: 43
Registriert: Sa 23. Nov 2019, 19:17
Hat sich bedankt: 47 Mal
Danksagung erhalten: 15 Mal

Re: PluginGuru

#22

Beitrag von dryeye »

danke...nun funktioniert es....übrigens auch mit audio-feeds wie z.b. diesem.....

Code: Alles auswählen

    { name = "Corona-Update mit C. Drosten",	        exec = "https://audiothek.ardmediathek.de/programsets/72451786/synd_rss?offset=0&limit=12"},
mfg dryeye
Folgende Benutzer bedankten sich beim Autor dryeye für den Beitrag (Insgesamt 2):
udog (Sa 6. Feb 2021, 17:30) • Frankenstone (Sa 6. Feb 2021, 18:04)
Bewertung: 15.38%
mfg dryeye
Benutzeravatar
Don de Deckelwech
Registrierte Benutzer
Registrierte Benutzer
Beiträge: 55
Registriert: Sa 3. Feb 2018, 13:20
Hat sich bedankt: 6 Mal
Danksagung erhalten: 23 Mal

Re: PluginGuru

#23

Beitrag von Don de Deckelwech »

Hi,
hmm, das erklärt es evtl, denn in der Version die ich installiert habe, steht noch? bzw schon? "RC.red". Die .lua hat den Zeitstempel 26.1. 18:30 .

Da es mich störte den roten Knopf drücken zu müssen, obwohl ich ja noch mit dem Daumen auf Ok lag, hab ich noch einen üblen Hack gemacht, damit man sowohl Rot als auch OK als auch Play drücken kann zum Starten des Beitrags: ;)

Zeile 192 so abändern:

Code: Alles auswählen

		elseif bRed and (msg == RC.red or msg == RC.ok or msg == RC.play) then
sowie Zeile 853 so:

Code: Alles auswählen

	if (selected == RC.red or selected == RC.ok or selected == RC.play) and vPlay and UrlVideo then
Ciao,
DdD.
Folgende Benutzer bedankten sich beim Autor Don de Deckelwech für den Beitrag (Insgesamt 3):
Frankenstone (Sa 6. Feb 2021, 18:04) • dryeye (Sa 6. Feb 2021, 18:05) • udog (Sa 6. Feb 2021, 20:01)
Bewertung: 23.08%
Benutzeravatar
BPanther
Administrator
Administrator
Beiträge: 11760
Registriert: Do 11. Jan 2007, 00:06
Wohnort: Berlin
Hat sich bedankt: 351 Mal
Danksagung erhalten: 578 Mal
Kontaktdaten:

Re: PluginGuru

#24

Beitrag von BPanther »

RC.play funktioniert nicht, da nicht definiert.
Folgende Benutzer bedankten sich beim Autor BPanther für den Beitrag (Insgesamt 2):
Frankenstone (Sa 6. Feb 2021, 18:39) • udog (Sa 6. Feb 2021, 19:58)
Bewertung: 15.38%
MfG BPanther
KEIN SUPPORT PER PN -> Bitte das Forum nutzen und das Wiki lesen.


Bild Bild
Thx udog für das Bild.
TV: Sony Bravia KDL-46HX755
Boxen mit NMP und Unicable2 (Jess):
SH4: 7x UFS910 (1W, 128MB), 1x UFS910 (14W, 64MB), 1x UFS912, 2x UFS913, 1x AV700, 1x AV7000, 1x AV7500 (DVB-S/C/T), 1x Edision Argus Pingulux, 1x Vizyon820HD
MIPS: 1x VU+DUO, 1x DM8000
ARM: 3x AX 4K HD51 (DVB-S/SX/C/T/T2), 1x VU+Solo4K (DVB-S/SX (FBC)/C/T/T2 (DUAL)), 1x VU+Duo4K (DVB-S/SX (FBC)/C (FBC)),
ARM: 1x VU+Duo4KSE (DVB-S/SX (FBC)/C (FBC)), 1x VU+Ultimo4K (DVB-S/SX (FBC)/C (DUAL)), 1x VU+Uno4KSE (DVB-S/SX (FBC)/C (FBC)), 2x VU+Zero4K (DVB-S/SX)
Benutzeravatar
Don de Deckelwech
Registrierte Benutzer
Registrierte Benutzer
Beiträge: 55
Registriert: Sa 3. Feb 2018, 13:20
Hat sich bedankt: 6 Mal
Danksagung erhalten: 23 Mal

Re: PluginGuru

#25

Beitrag von Don de Deckelwech »

Hi,
och menno, ich hatte nur auf der CST Tank getestet, aber mit RC.playpause statt RC.play klappts auch auf der HD51... ;)

Ciao,
DdD.

edit: also dann insgesamt so:
elseif bRed and (msg == RC.red or msg == RC.ok or msg == RC.play or msg == RC.playpause) then

if (selected == RC.red or selected == RC.ok or selected == RC.play or selected == RC.playpause) and vPlay and UrlVideo then
Benutzeravatar
Frankenstone
Co-Admin
Co-Admin
Beiträge: 2876
Registriert: Mo 4. Jul 2011, 21:19
Wohnort: Pott
Hat sich bedankt: 210 Mal
Danksagung erhalten: 142 Mal
Kontaktdaten:

Re: PluginGuru

#26

Beitrag von Frankenstone »

Negativ auf HD51 mit RC.playpause.
Auch nicht definiert.
KEIN SUPPORT PER PN !
Fragen über PN zum DDT oder meinem GIT werden kommentarlos gelöscht !
Bitte das Forum benutzen und in das Wiki schauen.


1* Mut@nt HD51 4K Ultra HD Linux Receiver mit 2 x DVB-S2X Si 2166D
1* AX HD51 4K Ultra HD Linux Receiver mit 2 x DVB-S2 AVL 6211
1* BRE2ZE4K DVB-S2 AVL 6211
4* UFS 913
2* UFS910 ausser betrieb ( Rentner :mrgreen: )
1* Banana Pi Pro
1* Inverto Unicable2 32-fach Quattro Multischalter IDLU-UST110-CUO1O-32P Raster 60 MHz 2*16
1* Toshiba TL 868 TV
1* LG TV
Benutzeravatar
BPanther
Administrator
Administrator
Beiträge: 11760
Registriert: Do 11. Jan 2007, 00:06
Wohnort: Berlin
Hat sich bedankt: 351 Mal
Danksagung erhalten: 578 Mal
Kontaktdaten:

Re: PluginGuru

#27

Beitrag von BPanther »

Play oder auch PlayPause können nicht funktionieren, nicht definiert. Einfach in Neutrino nachschauen, dazu hatte ich schonmal was geschrieben.

EDIT: Habe hier auch die Änderungen bezüglich RC.ok wieder entfernt, da die einen Nebeneffekt hatten. EXIT startete nämlich auch den Film auf einmal.
MfG BPanther
KEIN SUPPORT PER PN -> Bitte das Forum nutzen und das Wiki lesen.


Bild Bild
Thx udog für das Bild.
TV: Sony Bravia KDL-46HX755
Boxen mit NMP und Unicable2 (Jess):
SH4: 7x UFS910 (1W, 128MB), 1x UFS910 (14W, 64MB), 1x UFS912, 2x UFS913, 1x AV700, 1x AV7000, 1x AV7500 (DVB-S/C/T), 1x Edision Argus Pingulux, 1x Vizyon820HD
MIPS: 1x VU+DUO, 1x DM8000
ARM: 3x AX 4K HD51 (DVB-S/SX/C/T/T2), 1x VU+Solo4K (DVB-S/SX (FBC)/C/T/T2 (DUAL)), 1x VU+Duo4K (DVB-S/SX (FBC)/C (FBC)),
ARM: 1x VU+Duo4KSE (DVB-S/SX (FBC)/C (FBC)), 1x VU+Ultimo4K (DVB-S/SX (FBC)/C (DUAL)), 1x VU+Uno4KSE (DVB-S/SX (FBC)/C (FBC)), 2x VU+Zero4K (DVB-S/SX)
Benutzeravatar
Frankenstone
Co-Admin
Co-Admin
Beiträge: 2876
Registriert: Mo 4. Jul 2011, 21:19
Wohnort: Pott
Hat sich bedankt: 210 Mal
Danksagung erhalten: 142 Mal
Kontaktdaten:

Re: PluginGuru

#28

Beitrag von Frankenstone »

Kann ich so wie BP bestätigen.
KEIN SUPPORT PER PN !
Fragen über PN zum DDT oder meinem GIT werden kommentarlos gelöscht !
Bitte das Forum benutzen und in das Wiki schauen.


1* Mut@nt HD51 4K Ultra HD Linux Receiver mit 2 x DVB-S2X Si 2166D
1* AX HD51 4K Ultra HD Linux Receiver mit 2 x DVB-S2 AVL 6211
1* BRE2ZE4K DVB-S2 AVL 6211
4* UFS 913
2* UFS910 ausser betrieb ( Rentner :mrgreen: )
1* Banana Pi Pro
1* Inverto Unicable2 32-fach Quattro Multischalter IDLU-UST110-CUO1O-32P Raster 60 MHz 2*16
1* Toshiba TL 868 TV
1* LG TV
Benutzeravatar
Don de Deckelwech
Registrierte Benutzer
Registrierte Benutzer
Beiträge: 55
Registriert: Sa 3. Feb 2018, 13:20
Hat sich bedankt: 6 Mal
Danksagung erhalten: 23 Mal

Re: PluginGuru

#29

Beitrag von Don de Deckelwech »

Hi,
ihr macht mich fertig! :lol:

Versucht ihr da noch das Fenster zu ändern, also den angzeigten Button zum Starten? Das hab ich doch garnicht gewollt, sondern trotz angezeigtem rotem Button kann man einfach auch OK bzw Play(pause) drücken. Deshalb ja "übler Hack". ;)
Ich hab grad nochmal getetet, sowohl CST als auch HD51 funzt mit allen 3 (jeweils möglichen) Tasten im NI-Image , und es gibt auch keine Fehlbedienung durch Exit oder so...

Nur zum Verständnis, in der function get_input( ... ) Zeile 181 bis 210 werden die Fernbedienungscodes von Neutrino ausgewertet und als Rückgabewert zurückgereicht. Eigentlich ja nur Rot, dort hab ich aber einfach noch die zusätzlichen Tasten mitgenommen.

Und in Zeile 853 wird dann auch noch zusätzlich zu Rot auf die 3 zus. Tasten geprüft, um den Film zu starten.

Was soll da wo in Neutrino nicht definiert sein (müssen)??? Die ganzen Tastencodes kennt Neutrino doch wohl?

Ciao,
DdD.
Folgende Benutzer bedankten sich beim Autor Don de Deckelwech für den Beitrag (Insgesamt 2):
blacky49 (Sa 6. Feb 2021, 19:58) • udog (Sa 6. Feb 2021, 20:03)
Bewertung: 15.38%
Benutzeravatar
udog
Moderator
Moderator
Beiträge: 1422
Registriert: Mi 6. Jul 2011, 11:18
Wohnort: Thüringer (Altenburger Land)
Hat sich bedankt: 179 Mal
Danksagung erhalten: 91 Mal
Kontaktdaten:

Re: PluginGuru

#30

Beitrag von udog »

Don de Deckelwech hat geschrieben: Sa 6. Feb 2021, 18:45 Hi,
och menno, ich hatte nur auf der CST Tank getestet, aber mit RC.playpause statt RC.play klappts auch auf der HD51... ;)

Ciao,
DdD.

edit: also dann insgesamt so:
elseif bRed and (msg == RC.red or msg == RC.ok or msg == RC.play or msg == RC.playpause) then

if (selected == RC.red or selected == RC.ok or selected == RC.play or selected == RC.playpause) and vPlay and UrlVideo then
@ Don de Deckelwech
soweit ganz gut gelöst :thumbs: .Gut wäre wenn die Filmbeschreibung im Hintergrund verschwindet
da beim zweitem EXIT der Film wieder los geht zumindest hier auf HD51
Antworten

Zurück zu „Tools/Plugins/Senderlisten“