[Wunsch/Anregung] fehlende Software-Lüftersteuerung (Cuberevo / IPBox 9000)

Vorschläge was dem Image fehlt oder was besser gemacht werden kann.
Benutzeravatar
satmonk
Registrierte Benutzer
Registrierte Benutzer
Beiträge: 12
Registriert: Do 4. Aug 2016, 19:34
Hat sich bedankt: 3 Mal
Danksagung erhalten: 2 Mal

fehlende Software-Lüftersteuerung (Cuberevo / IPBox 9000)

#1

Beitrag von satmonk »

An dieser Stelle erst einmal ganz vielen Dank für die Unterstützung der IPBOX 9000 (Cuberevo / Vizyon).

Bisher hatte ich die Hoffnung das irgendwann mal der Lüfter beim Booten des Neutrino Image sich nicht mehr einfach ausschaltet. Das Neutrino Image gibt der Hardware einen Befehl, das der Lüfter ausgeschalten werden soll. Schade :-( Ohne eingeschaltenem Lüfter würde die Festplatte bzw. insbesondere die sich darunter auf dem IPBox Mainboard sitzenden IC's überhitzen.

Leider kann ich daher das Neutrino nicht benutzten. Gibt es da einen Script oder einen Befehl für Telnet, um den Lüfter wieder einzuschalten?

Im Neutrino Verzeichnis /bin habe ich die fp_control Datei gefunden, da steht etwas von:

Code: Alles auswählen

--setFan               Args: 0/1
	set fan on/off
EDIT:
Mit folgendem Telnet Befehl kann ich den Lüfter einschalten:

Code: Alles auswählen

fp_control -sf 1
Was muss ich tun, damit das dauerhaft so bleibt? Auch sollten andere Cuberevo Nutzer vor Überhitzung der Box geschützt sein, das Einschalten des Lüfters beim Bootvorgang sollte in jedem Fall in künftige Neutrino Images implementiert werden, wäre sonst schade um die Boxen und traurig für deren Besitzer.
Zuletzt geändert von satmonk am So 19. Jan 2020, 15:14, insgesamt 1-mal geändert.

Benutzeravatar
BPanther
Administrator
Administrator
Beiträge: 11020
Registriert: Do 11. Jan 2007, 00:06
Wohnort: Berlin
Hat sich bedankt: 228 Mal
Danksagung erhalten: 369 Mal
Kontaktdaten:

Re: fehlende Software-Lüftersteuerung (Cuberevo / IPBox 9000)

#2

Beitrag von BPanther »

Hast du denn auch die Lüfter-Geschwindigkeit eingestellt? Unter Einstellungen->Erweitert->Allgemein sollte da die Steuerung zu finden sein.
MfG BPanther
KEIN SUPPORT PER PN -> Bitte das Forum nutzen und das Wiki lesen.


Bild Bild
Thx udog für das Bild.
TV: Sony Bravia KDL-46HX755, Sony Bravia KDL-40W4500 (old)
Boxen mit NMP: 7x UFS910 (128MB), UFS912, 2x UFS913, AV700, AV7000, AV7500 (DVB-S/C/T), Edision Argus Pingulux, Vizyon820HD,
3x AX 4K HD51 (DVB-S/SX/C/T/T2), VU+DUO, VU+Solo4K (DVB-S/SX (FBC)/C/T/T2 (DUAL)), VU+Duo4K (DVB-S/SX (FBC)/C (FBC)),
VU+Ultimo4K (DVB-S/SX (FBC)/C (DUAL)), VU+Uno4KSE (DVB-S/SX (FBC)/C (FBC)), 2xVU+Zero4K (DVB-S/SX)

Benutzeravatar
satmonk
Registrierte Benutzer
Registrierte Benutzer
Beiträge: 12
Registriert: Do 4. Aug 2016, 19:34
Hat sich bedankt: 3 Mal
Danksagung erhalten: 2 Mal

Re: fehlende Software-Lüftersteuerung (Cuberevo / IPBox 9000)

#3

Beitrag von satmonk »

BPanther hat geschrieben:
So 19. Jan 2020, 14:56
Hast du denn auch die Lüfter-Geschwindigkeit eingestellt? Unter Einstellungen->Erweitert->Allgemein sollte da die Steuerung zu finden sein.
Danke für die schnelle Antwort.
Habe schon eine Teillösung gefunden siehe oben (editierter Beitrag). :party9:
Unter den Einstellungen hatte ich zu allererst geschaut, nur unterstützt die Hardware keine variable Lüftergeschwindigkeit. Egal was ich einstelle, der Lüfter blieb aus. Für diese Box Hardware gibt es nur 12V on oder off.
Zuletzt geändert von satmonk am So 19. Jan 2020, 17:46, insgesamt 1-mal geändert.

Benutzeravatar
satmonk
Registrierte Benutzer
Registrierte Benutzer
Beiträge: 12
Registriert: Do 4. Aug 2016, 19:34
Hat sich bedankt: 3 Mal
Danksagung erhalten: 2 Mal

Re: fehlende Software-Lüftersteuerung (Cuberevo / IPBox 9000)

#4

Beitrag von satmonk »

OK, hab erst mal diese Lösung gefunden:

Den Eintrag

Code: Alles auswählen

fp_control -sf 1
in die Text-Datei "voremu.sh" eintragen (zu finden bei /var/etc/) und speichern. Dadurch wird bei jedem Bootvorgang der Lüfter eingeschalten und nichts kann überhitzen. :)

Benutzeravatar
BPanther
Administrator
Administrator
Beiträge: 11020
Registriert: Do 11. Jan 2007, 00:06
Wohnort: Berlin
Hat sich bedankt: 228 Mal
Danksagung erhalten: 369 Mal
Kontaktdaten:

Re: fehlende Software-Lüftersteuerung (Cuberevo / IPBox 9000)

#5

Beitrag von BPanther »

Die Zeile kann in die vorneutrino.sh mit rein.

Aber schau mal in Telnet oder per FTP nach, ob folgendes existiert:

/proc/stb/misc/fan
/proc/stb/fan/fan_ctrl

Ich gehe mal von /proc/stb/misc/fan aus. Abfrage in Telnet mit cat /proc/stb/misc/fan - sollte dann 1 oder 0 ergeben. Wenn dem so ist, ist das im GIT entsprechend nicht richtig verbaut.
MfG BPanther
KEIN SUPPORT PER PN -> Bitte das Forum nutzen und das Wiki lesen.


Bild Bild
Thx udog für das Bild.
TV: Sony Bravia KDL-46HX755, Sony Bravia KDL-40W4500 (old)
Boxen mit NMP: 7x UFS910 (128MB), UFS912, 2x UFS913, AV700, AV7000, AV7500 (DVB-S/C/T), Edision Argus Pingulux, Vizyon820HD,
3x AX 4K HD51 (DVB-S/SX/C/T/T2), VU+DUO, VU+Solo4K (DVB-S/SX (FBC)/C/T/T2 (DUAL)), VU+Duo4K (DVB-S/SX (FBC)/C (FBC)),
VU+Ultimo4K (DVB-S/SX (FBC)/C (DUAL)), VU+Uno4KSE (DVB-S/SX (FBC)/C (FBC)), 2xVU+Zero4K (DVB-S/SX)

Benutzeravatar
satmonk
Registrierte Benutzer
Registrierte Benutzer
Beiträge: 12
Registriert: Do 4. Aug 2016, 19:34
Hat sich bedankt: 3 Mal
Danksagung erhalten: 2 Mal

Re: fehlende Software-Lüftersteuerung (Cuberevo / IPBox 9000)

#6

Beitrag von satmonk »

Nein, keines dieser Verzeichnisse existiert
fan.jpg
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.

Benutzeravatar
BPanther
Administrator
Administrator
Beiträge: 11020
Registriert: Do 11. Jan 2007, 00:06
Wohnort: Berlin
Hat sich bedankt: 228 Mal
Danksagung erhalten: 369 Mal
Kontaktdaten:

Re: fehlende Software-Lüftersteuerung (Cuberevo / IPBox 9000)

#7

Beitrag von BPanther »

Hmm... Was sagt
cat /proc/stb/misc/12V_output

Und dann nochmal abfragen nach umstellen mit fp_control -sf 0

Wenn sich da der Wert ändert, könne es das sein, ansonsten müsste man suchen, ob man woanders was unter proc findet, z.B. mit
find /proc -name *fan*
MfG BPanther
KEIN SUPPORT PER PN -> Bitte das Forum nutzen und das Wiki lesen.


Bild Bild
Thx udog für das Bild.
TV: Sony Bravia KDL-46HX755, Sony Bravia KDL-40W4500 (old)
Boxen mit NMP: 7x UFS910 (128MB), UFS912, 2x UFS913, AV700, AV7000, AV7500 (DVB-S/C/T), Edision Argus Pingulux, Vizyon820HD,
3x AX 4K HD51 (DVB-S/SX/C/T/T2), VU+DUO, VU+Solo4K (DVB-S/SX (FBC)/C/T/T2 (DUAL)), VU+Duo4K (DVB-S/SX (FBC)/C (FBC)),
VU+Ultimo4K (DVB-S/SX (FBC)/C (DUAL)), VU+Uno4KSE (DVB-S/SX (FBC)/C (FBC)), 2xVU+Zero4K (DVB-S/SX)

Benutzeravatar
satmonk
Registrierte Benutzer
Registrierte Benutzer
Beiträge: 12
Registriert: Do 4. Aug 2016, 19:34
Hat sich bedankt: 3 Mal
Danksagung erhalten: 2 Mal

Re: fehlende Software-Lüftersteuerung (Cuberevo / IPBox 9000)

#8

Beitrag von satmonk »

12V_output = off
fan.jpg
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.

Benutzeravatar
BPanther
Administrator
Administrator
Beiträge: 11020
Registriert: Do 11. Jan 2007, 00:06
Wohnort: Berlin
Hat sich bedankt: 228 Mal
Danksagung erhalten: 369 Mal
Kontaktdaten:

Re: fehlende Software-Lüftersteuerung (Cuberevo / IPBox 9000)

#9

Beitrag von BPanther »

Ok, also mit *fan* gibts nichts unter /proc.

Und der 12 Output bleibt immer "off", egal ob Lüfter ein oder aus? Weil dann sieht das schlecht aus und muß dann komplett anders gemacht werden. In Neutrino ist nur die Steuerung über /proc vorgesehen.
MfG BPanther
KEIN SUPPORT PER PN -> Bitte das Forum nutzen und das Wiki lesen.


Bild Bild
Thx udog für das Bild.
TV: Sony Bravia KDL-46HX755, Sony Bravia KDL-40W4500 (old)
Boxen mit NMP: 7x UFS910 (128MB), UFS912, 2x UFS913, AV700, AV7000, AV7500 (DVB-S/C/T), Edision Argus Pingulux, Vizyon820HD,
3x AX 4K HD51 (DVB-S/SX/C/T/T2), VU+DUO, VU+Solo4K (DVB-S/SX (FBC)/C/T/T2 (DUAL)), VU+Duo4K (DVB-S/SX (FBC)/C (FBC)),
VU+Ultimo4K (DVB-S/SX (FBC)/C (DUAL)), VU+Uno4KSE (DVB-S/SX (FBC)/C (FBC)), 2xVU+Zero4K (DVB-S/SX)

Benutzeravatar
satmonk
Registrierte Benutzer
Registrierte Benutzer
Beiträge: 12
Registriert: Do 4. Aug 2016, 19:34
Hat sich bedankt: 3 Mal
Danksagung erhalten: 2 Mal

Re: fehlende Software-Lüftersteuerung (Cuberevo / IPBox 9000)

#10

Beitrag von satmonk »

ja, bleibt immer auf "off", egal ob Lüfter an oder aus.

Hier der Serial Log (Bootvorgang, ohne Lüftermodifikation, also Neutrino-Originalzustand)

Code: Alles auswählen

Rebooting... /bin/fp_control: SW Version 1.04
Model: cuberevo
vBoxType: 8
Selected Model: CUBEREVO frontpanel control utility
init
configs: DISPLAY = 1, DISPLAYCUSTOM = 1, CUSTOM =     %H:%M:%S    
, WAKEUPDECREMENT 300



U-Boot 1.3.1 (Aug 10 2010 - 16:31:50) - stm23-2008-03-19
Board: cuberevo (0x2D42C041)
Board: 13 grid vfd front
DRAM:  128 MB
Flash: 32 MB
In:    serial
Out:   serial
Err:   serial
Reserve 0x2010000 bytes from 0xa5ff0000 for DGS upgrade buffer.
Setup mac address.
booting...

Reset IDE: Bus 0: OK 
  Device 0: Model: SAMSUNG HD204UI  Firm: 1AQ10001 Ser#: xxxxxxxxxxxxxx
            Type: Hard Disk
            Supports 48-bit addressing
            Capacity: 1907729.0 MB = 1863.0 GB (-387938128 x 512)

1907377 bytes read
## Booting image at a5ff0000 ...
   Image Name:   Linux-2.6.32.71_stm24_0217
   Image Type:   SuperH Linux Kernel Image (gzip compressed)
   Data Size:    1907313 Bytes =  1.8 MB
   Load Address: 84001000
   Entry Point:  84002000
   Verifying Checksum ... OK
   Uncompressing Kernel Image ... OK

Warning: Unable to determine if kernel is built for 29- or 32-bit mode!

Starting kernel console=ttyAS1,115200 panic=3 root=/dev/sda3 rw rootdelay=10 init=/bin/devinit ip=192.168.1.5:192.168.1.6:192.168.1.1:255.255.255.0 mem=128m coprocessor_mem=4m@0x10000000,4m@0x10400000 - 0x00000000 - 0 ...


INIT: version 2.96 booting


INIT: Entering runlevel: 3



192.168.1.5 login: BPanther-Image rev18332-ddt
[mountvirtfs] Mount /dev in tmpfs
[mountvirtfs] Copying device nodes to /dev
/etc/mdev/mdev-mount.sh: line 91: logger: not found
/etc/mdev/mdev-mount.sh: line 99: logger: not found
/etc/mdev/mdev-mount.sh: line 99: logger: not found
/etc/mdev/mdev-mount.sh: line 99: logger: not found
[mountall] Mounting local filesystems...
Cleaning /tmp.
Hostname: cuberevo.
Deconfiguring network interfaces... ifdown: interface lo not configured
ifdown: interface eth0 not configured
done.
Setting up IP spoofing protection: rp_filter.
Configuring network interfaces... done.
Starting portmap daemon....
4096+0 records in
4096+0 records out
4194304 bytes (4.0MB) copied, 0.076352 seconds, 52.4MB/s
copLoadFile (file /lib/firmware/video.elf)
ustslave: Kernel Version: 24
base_address 0x10000000
seeking to 0
seeking to 4e020
seeking to f8378
seeking to f83b0
seeking to f83e8
seeking to 10ce98
seeking to 10cea4
seeking to 10ceb0
seeking to 12ed90
seeking to 12cd74
seeking to 12ee00
4096+0 records in
4096+0 records out
4194304 bytes (4.0MB) copied, 0.075255 seconds, 53.2MB/s
copLoadFile (file /lib/firmware/audio.elf)
ustslave: Kernel Version: 24
base_address 0x10400000
seeking to 0
seeking to 5f00
seeking to 12320
seeking to 1aa20
seeking to 173100
seeking to 173138
seeking to 173170
seeking to 1b9058
seeking to 1b9060
seeking to 1b9068
seeking to 1b9070
seeking to 1d0920
seeking to 1d0a00
rdate: timeout connecting to time server
Thu Jan 16 04:34:00 CET 2020
showSinglePic /var/boot/bootlogo.mvi
VIDEO_SELECT_SOURCE MEMORY (Success)
VIDEO_PLAY (Success)
VIDEO_CONTINUE: (Success)
VIDEO_CLEAR_BUFFER: (Invalid argument)
swapoff: /dev/ramzswap0: No such file or directory
rmmod: can't unload module 'ramzswap': No such file or directory
Model: 'cuberevo'
vBoxType: 8
Input device name: "TDT RC event driver"
Selected Remote: Cuberevo RemoteControl
RemoteControl Map:
              KEY_F1 - 00 -  59
              KEY_F2 - 01 -  60
              KEY_F3 - 02 -  61
                INFO - 03 - 358
               RADIO - 04 - 385
            PREVIOUS - 05 - 412
                 EPG - 06 - 365
              RECORD - 07 - 167
           FAVORITES - 08 - 364
               MEDIA - 09 - 226
             STANDBY - 0A - 116
              KEY_F5 - 0B -  63
                MUTE - 0C - 113
             ARCHIVE - 0D - 361
             0BUTTON - 10 -  11
             1BUTTON - 11 -   2
             2BUTTON - 12 -   3
             3BUTTON - 13 -   4
             4BUTTON - 14 -   5
             5BUTTON - 15 -   6
             6BUTTON - 16 -   7
             7BUTTON - 17 -   8
             8BUTTON - 18 -   9
             9BUTTON - 19 -  10
                  UP - 1A - 103
                DOWN - 1B - 108
               RIGHT - 1C - 106
                LEFT - 1D - 105
              REWIND - 1E - 168
                  OK - 1F - 352
                PLAY - 20 - 207
         FASTFORWARD - 21 - 208
                STOP - 22 - 128
                SLOW - 23 - 409
               AGAIN - 24 - 129
               PAUSE - 25 - 119
                MENU - 26 - 139
                EXIT - 27 - 102
              KEY_F7 - 28 -  65
        KEY_BOOMARKS - 29 - 156
                 RED - 2A - 398
                BLUE - 2B - 401
              KEY_F8 - 2C -  66
               GREEN - 2D - 399
              YELLOW - 2E - 400
               AUDIO - 2F - 392
            SUBTITLE - 30 - 370
                TEXT - 31 - 388
           CHANNELUP - 32 - 402
         CHANNELDOWN - 33 - 403
            VOLUMEUP - 34 - 115
          VOLUMEDOWN - 35 - 114
                 WWW - 36 - 150
Supports Long KeyPress: 1
processComplex >
period 140, delay 10
micom version = 1
Using period=140 delay=10
[SEM] DOWN
/bin/fp_control: SW Version 1.04
Model: cuberevo
vBoxType: 8
Selected Model: CUBEREVO frontpanel control utility
init
configs: DISPLAY = 1, DISPLAYCUSTOM = 1, CUSTOM =     %H:%M:%S    
, WAKEUPDECREMENT 300
[ca_ci] -> GetInstance
[ca_ci] -> cCA 0
>>> Neutrino (compiled Jan 16 2020 04:34:31) <<<
libstb-hal debug options can be set by exporting HAL_DEBUG.
The following values (or bitwise OR combinations) are valid:
	component: audio   0x01
	component: video   0x02
	component: demux   0x04
	component: play    0x08
	component: power   0x10
	component: init    0x20
	component: ca      0x40
	component: record  0x80
	all components:    0xff
[HAL:00000000:init  ] hal_api_init begin, initialized=0, debug=0x00
[HAL:00000000:init  ] hal_api_init end
[neutrino] frameBuffer Instance created
12288k video mem
CFrameBuffer::setMode avail: 12582912 active: 1
FB: 1280x720x32 line length 5120.
[neutrino] executing /var/tuxbox/config/neutrino.start.
/var/tuxbox/config/neutrino.start failed: No such file or directory
[neutrino] set debuglevel: 0
[HAL:00000000:init  ] hal_api_init begin, initialized=1, debug=0x00
[HAL:00000000:init  ] hal_api_init end
[neutrino] recording dir: /hdd/movie
[neutrino] timeshift dir: /hdd/movie/.timeshift
[HAL:007c6ac8:power ] SetCpuFreq(0) => set standby = false
[timerd] wakeup from standby: no
[neutrino.cpp] executing /var/tuxbox/config/deepstandby.off.
[neutrino CEC Settings] setCECSettings init CEC settings...
[neutrino] [CNeutrinoFonts] [SetupNeutrinoFonts - 169] font file: /usr/share/fonts/neutrino.ttf
[neutrino] [CNeutrinoFonts] [SetupNeutrinoFonts - 191] standard font family: Arial Narrow
[neutrino] [CNeutrinoFonts] [SetupDynamicFonts - 151] dynamic font family: Arial Narrow
CVFD::setlcdparameter dimm 5 power 1
CVFD::showServicename: 
CVFD::ShowScrollText: [Tuxbox-Neutrino 3.7.7 wird gestartet ...]
[fe0/0] frontend fd 9 type 0
[frontend.cpp:getFEInfo:390] ioctl(fd, FE_GET_PROPERTY, &cmdseq): Operation not permitted
WARNING: can't query delivery systems on frontend 0/0 - falling back to legacy mode
[femanager.cpp:Init:104] add fe 0
[frontend.cpp:Open:302] /dev/dvb/adapter0/frontend1: No such device
[frontend.cpp:Open:302] /dev/dvb/adapter0/frontend2: No such file or directory
[frontend.cpp:Open:302] /dev/dvb/adapter0/frontend3: No such file or directory
[frontend.cpp:Open:302] /dev/dvb/adapter1/frontend0: No such file or directory
[frontend.cpp:Open:302] /dev/dvb/adapter1/frontend1: No such file or directory
[frontend.cpp:Open:302] /dev/dvb/adapter1/frontend2: No such file or directory
[frontend.cpp:Open:302] /dev/dvb/adapter1/frontend3: No such file or directory
[frontend.cpp:Open:302] /dev/dvb/adapter2/frontend0: No such file or directory
[frontend.cpp:Open:302] /dev/dvb/adapter2/frontend1: No such file or directory
[frontend.cpp:Open:302] /dev/dvb/adapter2/frontend2: No such file or directory
[frontend.cpp:Open:302] /dev/dvb/adapter2/frontend3: No such file or directory
[frontend.cpp:Open:302] /dev/dvb/adapter3/frontend0: No such file or directory
[frontend.cpp:Open:302] /dev/dvb/adapter3/frontend1: No such file or directory
[frontend.cpp:Open:302] /dev/dvb/adapter3/frontend2: No such file or directory
[frontend.cpp:Open:302] /dev/dvb/adapter3/frontend3: No such file or directory
[femanager.cpp:Init:120] found 1 frontends, 4 demuxes

[zapit] Loading services, channel size 248 ..
[getservices.cpp:LoadServices:951] Loading satellites...
[getservices.cpp:FindTransponder:601] going to parse dvb-s provider 19.2E Ku-band Astra 1KR/1L/1M/1N
[zapit] 1407 services loaded (1407)...
[zapit] service loading took: 650 msec
[getservices.cpp:FindTransponder:601] going to parse dvb-s provider 19.2E Ku-band Astra 1KR/1L/1M/1N
[zapit.cpp:PrepareChannels:1072] LoadServices: success
[bouquets.cpp:parseBouquetsXml:417] reading bouquets from /var/tuxbox/config/zapit/bouquets.xml
[bouquets.cpp:parseBouquetsXml:519] total: 54 bouquets
[bouquets.cpp:loadWebchannels:892] Loading webtv from /var/tuxbox/config/webtv_usr.xml ...
[bouquets.cpp:loadWebchannels:892] Loading webradio from /var/tuxbox/config/webradio_usr.xml ...
[bouquets.cpp:parseBouquetsXml:417] reading bouquets from /var/tuxbox/config/zapit/ubouquets.xml
[bouquets.cpp:parseBouquetsXml:519] total: 73 bouquets
############## CBouquetManager::makeRemainingChannelsBouquet: numbers start at: tv 1 radio 1 ############
[zapit] bouquet loading took: 1378 msec
CServiceManager::SaveServices: total channels: 1418
CServiceManager::SaveServices: processed channels: 1407
[zapit.cpp:Start:2542] channels have been loaded succesfully
[zapit.cpp] diseqc type = 0
[femanager.cpp:loadSettings:248] load config for fe0
[femanager.cpp:linkFrontends:428] linking..
[femanager.cpp:linkFrontends:470] Frontend #0: is master, with loop: no, with rotor: no
[frontend.cpp:setDiseqcType:1813] fe0: NO_DISEQC
[femanager.cpp:linkFrontends:496] pip demux: 2
[ca_ci] -> SetInitMask param:3
[ca_ci] -> SetTSClock to: high
[ca_ci] -> Start
[zapit] GetConfig...
[zapit] starting... tid 1032
[neutrino VideoSettings] setupVideoSystem setup videosystem...
[neutrino VideoSettings] setVideoSettings init video settings...
[rcinput:checkdev] /dev/input mtime changed
[rcinput:open] open /dev/input/js1 failed: No such device
[rcinput:open] open /dev/input/mouse1 failed: No such device
[rcinput:open] opened /dev/input/event0 (fd 23) ev 0x100003
[rcinput:open] open /dev/input/mouse3 failed: No such device
[zapit] sdt monitor started
[rcinput:open] open /dev/input/event2 failed: No such device
[rcinput:open] open /dev/input/mouse2 failed: No such device
[rcinput:open] open /dev/input/mouse0 failed: No such device
[rcinput:open] open /dev/input/event3 failed: No such device
[rcinput:open] open /dev/input/js0 failed: No such device
[rcinput:open] open /dev/input/js2 failed: No such device
[rcinput:open] open /dev/input/mice failed: No such device
[rcinput:open] open /dev/input/js3 failed: No such device
[rcinput:open] open /dev/input/event1 failed: No such device
[zapit.cpp:leaveStandby:2377] standby 1 recording 0
[zapit.cpp:ZapIt:520] [zapit] zap to rbb Berlin (bdf4043100016e2e tp 2f4d00c004310001)
[zapit] GetConfig...
[zapit.cpp:StopPlayBack:2300] standby 0 playing 0 forced 0 send_pmt 1
[fe0/0] tune to 12109000 DVB QPSK 3/4 H/L srate 27500000 pli 0 plc 1 plm 0 (tuner 1509000 offset 10600000 timeout 4000)
[frontend.cpp:getEvent:921] [fe0/0] ******** FE_HAS_LOCK: freq 1509000
[fe0/0] tuning took: 1725 msec (min 1725 max 1725)
[HAL:00838070:demux ] _open: setting /dev/dvb/adapter0/demux0 to source 0
[HAL:00838070:demux ] Read read: Connection timed out fd:24, ev:0x0 DMX_PSI pid:0x0000 flt:0x00
[pat.cpp] dmx read failed
[pat] sid 6e2e not found
[zapit] pat parsing failed
[zapit] ZapIt:2 SCR retry tuning 1 after 266ms
[fe0/0] tune to 12109000 DVB QPSK 3/4 H/L srate 27500000 pli 0 plc 1 plm 0 (tuner 1509000 offset 10600000 timeout 4000)
[fe0/0] FE_HAS_SIGNAL
[fe0/0] FE_HAS_SIGNAL
[fe0/0] FE_HAS_CARRIER
[fe0/0] FE_HAS_SIGNAL
[fe0/0] FE_HAS_SIGNAL
[fe0/0] FE_HAS_CARRIER
[fe0/0] FE_HAS_SIGNAL
[fe0/0] FE_HAS_SIGNAL
[fe0/0] FE_HAS_CARRIER
[fe0/0] FE_HAS_SIGNAL
[fe0/0] FE_HAS_SIGNAL
[fe0/0] FE_HAS_CARRIER
[fe0/0] ############################## poll timeout, time: 4004 msec (min 2000 max 4004)
[neutrino] g_info.has_fan: 1
FAN Speed 4
Cannot open /proc/stb/fan/fan_ctrl: No such file or directory
CStreamManager::Listen: on 31339, fd 17
timerd startup, tid 1052
[HAL:0083eec0:demux ] Stop #0: not open!
2020-01-16 04:34:28.568 [sectionsd] start
2020-01-16 04:34:28.574 [sectionsd] Caching: 3 days, 3 hours Extended Text, max 20000 events, Events are old 3 hours after end time
[yhttpd] Webserver nhttpd/3.4.1 (yhttpd_core/1.3.2) tid 1056
2020-01-16 04:34:28.574 [sectionsd] NTP: disabled, command /usr/sbin/ntpd -n -q -p time.fu-berlin.de
Starting STREAM thread keeper, tid 1057
2020-01-16 04:34:28.591 [sectionsd] starting
2020-01-16 04:34:28.591 [sectionsd] SIevent size: 88
2020-01-16 04:34:28.591 [sectionsd] ====> USING SLOW ADDEVENT. export 'NO_SLOW_ADDEVENT=1' to avoid <===
2020-01-16 04:34:28.677 [sectionsd] timeThread::run:: starting, pid 1008 (855639160)
2020-01-16 04:34:28.694 [sectionsd] timeThread: get DVB time ch 0x000000000000 (isOpen 1)
2020-01-16 04:34:28.700 [sectionsd] eitThread::run:: starting, pid 1008 (864027768)
2020-01-16 04:34:28.716 [sectionsd] cnThread::run:: starting, pid 1008 (872416376)
2020-01-16 04:34:28.730 [sectionsd] freeSatThread::run:: starting, pid 1008 (880804984)
[yhttpd] Webserver starting...
[neutrino] menue setup
[neutrino] init menus...
[neutrino] mediaplayer menu instance created
[ca_ci] -> GetNumberCISlots
[ca_ci] -> GetNumberSmartCardSlots
[network config] Instance created
[neutrino] [CNetworkSetup]	[getInstance - 89],  Instance created
[neutrino] ScanSetup Instance created
[HAL:2ce40208:play  ] cPlayback
[mb]->refreshBrowserList
[mb]->refreshFilterList 20
[neutrino CMoviePlayerGui] Instance created...
[neutrino] registering as event client
[neutrino] had to wait 0 ms for timerd start...
[neutrino] Creating channels lists...
[neutrino] got 1245 TV and 171 RADIO channels
[neutrino] all channels took: 4 msec
[neutrino] created 19.2E Ku-band Astra 1KR/1L/1M/1N (192) bouquet with 1245 TV and 160 RADIO channels
[neutrino] sat took: 45 msec
[neutrino] got 11 WebRadio channels
[neutrino] got 67 new TV channels
[neutrino] got 69 removed TV channels
[neutrino] sats took: 87 msec
[neutrino] got 56 TV and 24 RADIO bouquets
[neutrino] took: 99 msec
CNeutrinoApp::SetChannelMode 0 [tv]
[neutrino.cpp:SetChannelMode:2164] newmode 0 sort old -1 new 0
[neutrino.cpp:tvMode:4660] rezap 1 current mode 1
CVFD::showServicename: 
CRemoteControl::tvMode
CNeutrinoApp::SetChannelMode 0 [tv]
[neutrino.cpp:SetChannelMode:2164] newmode 0 sort old -1 new 0
**************************** CChannelList::zapTo_ChannelID bdf4043100016e2e
**************************** CChannelList::zapToChannel me 0x8c3bd8 Alle Kanäle tuned 268435455 new rbb Berlin -> bdf4043100016e2e
2020-01-16 04:34:30.027 [sectionsd] commandserviceStopped
2020-01-16 04:34:30.027 [sectionsd] cnThread: stop eit update filter (not active)
2020-01-16 04:34:30.028 [sectionsd] commandserviceStopped done
stopPlayBack: stopping...
stopPlayBack: stopped
CChannelList::adjustToChannelID me 0x8c3bd8 [Alle Kanäle] list size 1245 channel_id bdf4043100016e2e
[zapit.cpp:ZapIt:520] [zapit] zap to rbb Berlin (bdf4043100016e2e tp 2f4d00c004310001)
[zapit] saving channel, apid 0 sub pid 0 mode 0 volume 24
[zapit] GetConfig...
[zapit.cpp:StopPlayBack:2300] standby 0 playing 0 forced 0 send_pmt 1
2020-01-16 04:34:30.051 [sectionsd] commandserviceChanged: Service change to bdf4043100016e2e demux #0
2020-01-16 04:34:30.051 [sectionsd] changeDMX: for 0x4e not ignored! even though real_pauseCounter> 0 (1)
2020-01-16 04:34:30.052 [sectionsd] changeDMX: for 0x50 not ignored! even though real_pauseCounter> 0 (1)
2020-01-16 04:34:30.052 [sectionsd] changeDMX: for 0x60 not ignored! even though real_pauseCounter> 0 (1)
CHDDDestExec: checking /sys/block/sda
[ca_ci] -> Ready param:1
################################## after all ##################################: 18580 msec
[neutrino] initialized everything
[CPlugins] could not find startup
CRemoteControl::handleMsg: EVT_TUNE_COMPLETE (bdf4043100016e2e)
[fe0/0] tune to 12109000 DVB QPSK 3/4 H/L srate 27500000 pli 0 plc 1 plm 0 (tuner 1509000 offset 10600000 timeout 4000)
[HAL:00849c80:demux ] Read:1 ========== fd has changed, 32->-1 ==========
2020-01-16 04:34:31.711 [sectionsd] timeThread: get DVB time ch 0x043100016e2e rc: -1 neutrino_sets_time 0
2020-01-16 04:34:31.712 [sectionsd] timeThread: Time set FAILED (enabled: ntp 0 dvb 1)
2020-01-16 04:34:31.739 [sectionsd] commandserviceChanged: Service change to bdf4043100016e2e demux #0
[fe0/0] FE_HAS_SIGNAL
CRemoteControl::handleMsg: EVT_TUNE_COMPLETE (0000000000000000)
[fe0/0] FE_HAS_SIGNAL
[fe0/0] FE_HAS_CARRIER
2020-01-16 04:34:32.719 [sectionsd] timeThread: get DVB time ch 0x043100016e2e (isOpen 1)
[fe0/0] FE_HAS_SIGNAL
[fe0/0] FE_HAS_SIGNAL
[fe0/0] FE_HAS_CARRIER
[fe0/0] FE_HAS_SIGNAL
[fe0/0] FE_HAS_SIGNAL
[fe0/0] FE_HAS_CARRIER
[fe0/0] ############################## poll timeout, time: 4004 msec (min 2000 max 4004)
[zapit] ZapIt:1 SCR retry tuning 1 after 702ms
[fe0/0] tune to 12109000 DVB QPSK 3/4 H/L srate 27500000 pli 0 plc 1 plm 0 (tuner 1509000 offset 10600000 timeout 4000)
[fe0/0] FE_HAS_SIGNAL
[dvb-sub] start, stopped 1 pid 0
[HAL:0083eec0:demux ] Stop #0: not open!
[dvb-sub] started with pid 0xffffffff
[fe0/0] FE_HAS_SIGNAL
[fe0/0] FE_HAS_CARRIER
[fe0/0] FE_HAS_SIGNAL
[fe0/0] FE_HAS_SIGNAL
[fe0/0] FE_HAS_CARRIER
[fe0/0] FE_HAS_SIGNAL
[fe0/0] FE_HAS_SIGNAL
[fe0/0] FE_HAS_CARRIER
[fe0/0] FE_HAS_SIGNAL
[fe0/0] ############################## poll timeout, time: 4004 msec (min 2000 max 4004)
CRemoteControl::handleMsg: EVT_TUNE_COMPLETE (0000000000000000)
CVFD::showServicename: (rbb Berlin)
zap failed!
Problem scheint an dieser Stelle zu liegen:
[neutrino] g_info.has_fan: 1
FAN Speed 4
Cannot open /proc/stb/fan/fan_ctrl: No such file or directory
Folgende Benutzer bedankten sich beim Autor satmonk für den Beitrag:
BPanther (So 19. Jan 2020, 19:24)
Bewertung: 10%

Benutzeravatar
BPanther
Administrator
Administrator
Beiträge: 11020
Registriert: Do 11. Jan 2007, 00:06
Wohnort: Berlin
Hat sich bedankt: 228 Mal
Danksagung erhalten: 369 Mal
Kontaktdaten:

Re: fehlende Software-Lüftersteuerung (Cuberevo / IPBox 9000)

#11

Beitrag von BPanther »

satmonk hat geschrieben:
So 19. Jan 2020, 19:10
ja, bleibt immer auf "off", egal ob Lüfter an oder aus.
Schade, aber hatte ich auch irgendwo befürchtet. Das muß wohl direkt über den Frontcontroller gemacht werden.
satmonk hat geschrieben:
So 19. Jan 2020, 19:10
Problem scheint an dieser Stelle zu liegen:
[neutrino] g_info.has_fan: 1
FAN Speed 4
Cannot open /proc/stb/fan/fan_ctrl: No such file or directory
Nunja, das sagt nur, daß nichts angesprochen/gefunden werden kann, was ich auch befürchtet hatte und deswegen die Frage nach den Verzeichnissen. Nur komisch und auch ungewöhnlich, daß die Box im Standard den Lüfter abschaltet beim Start, denn Neutrino selbst kann das ja nicht wie man sieht.

Da bleibt erstmal nur der manuelle Eintrag in der vorneutrino.sh um den Lüfter zu aktivieren. Evtl. packe ich das gleiche in den Startvorgang mit rein, dann läuft er eben immer.
MfG BPanther
KEIN SUPPORT PER PN -> Bitte das Forum nutzen und das Wiki lesen.


Bild Bild
Thx udog für das Bild.
TV: Sony Bravia KDL-46HX755, Sony Bravia KDL-40W4500 (old)
Boxen mit NMP: 7x UFS910 (128MB), UFS912, 2x UFS913, AV700, AV7000, AV7500 (DVB-S/C/T), Edision Argus Pingulux, Vizyon820HD,
3x AX 4K HD51 (DVB-S/SX/C/T/T2), VU+DUO, VU+Solo4K (DVB-S/SX (FBC)/C/T/T2 (DUAL)), VU+Duo4K (DVB-S/SX (FBC)/C (FBC)),
VU+Ultimo4K (DVB-S/SX (FBC)/C (DUAL)), VU+Uno4KSE (DVB-S/SX (FBC)/C (FBC)), 2xVU+Zero4K (DVB-S/SX)

Benutzeravatar
satmonk
Registrierte Benutzer
Registrierte Benutzer
Beiträge: 12
Registriert: Do 4. Aug 2016, 19:34
Hat sich bedankt: 3 Mal
Danksagung erhalten: 2 Mal

Re: fehlende Software-Lüftersteuerung (Cuberevo / IPBox 9000)

#12

Beitrag von satmonk »

Der Lüfter schaltet sich automatisch ein wenn man die Box einschaltet. Der Lüfter schaltet sich exakt in dem Moment aus, sobald der Display von "Booting" nach "BPanther" wechselt. Dieses Verhalten (Lüfter an/Lüfter aus/Lüfter an) ist aber auch bei anderen Images (PKT/ HDMU) sehr ähnlich. Wie gesagt, bei Neutrino ist mir aufgefallen, das sich der Lüfter zwar ausschaltet, aber nicht wieder einschaltet und da schellten bei mir die Alarmglocken :-).

Sicher wird es so sein, das die IPBox Firmware selbst den Lüfter ausschaltet, kurz bevor das Image geladen wird (das würde erklären warum sich der Lüfter in dem Moment beim Displaytextwechsel "Booting"/"BPanther" ausschaltet)

Irgendwie scheint beim Image Kompilieren die Datei "fan_ctrl" nicht mitgenommen worden zu sein.
Die fehlende Lüfterfunktion ist schon länger so, mindestens seit 2016, hatte damals aber ganz vergessen das mitzuteilen :kopf_wand: und die letzten 3 Jahre habe ich das Gerät eher nur selten zu Aufnahmezwecken (mit PKT) genutzt und mich nicht weiter darum gekümmert.

EDIT:
Beim PKT sieht es aber auch so aus wie beim Neutrino
cat /proc/stb/misc/12V_output
off

auch dort existieren keine fan Ordner, weder in in "misc" noch in "stb"

trotzdem wird der Lüfter eingeschalten

Benutzeravatar
BPanther
Administrator
Administrator
Beiträge: 11020
Registriert: Do 11. Jan 2007, 00:06
Wohnort: Berlin
Hat sich bedankt: 228 Mal
Danksagung erhalten: 369 Mal
Kontaktdaten:

Re: fehlende Software-Lüftersteuerung (Cuberevo / IPBox 9000)

#13

Beitrag von BPanther »

Nun, warum das abschaltet genau bei dem Displaywechsel könnte ich mir evtl. damit erklären, daß dann die Hauptmodule geladen wurden, daß also von da kommt.

/proc/stb/fan/fan_ctrl anlegen zu lassen ist nicht das Problem, nur reicht das bei weitem nicht, denn der dazugehörige Treiber fehlt.
MfG BPanther
KEIN SUPPORT PER PN -> Bitte das Forum nutzen und das Wiki lesen.


Bild Bild
Thx udog für das Bild.
TV: Sony Bravia KDL-46HX755, Sony Bravia KDL-40W4500 (old)
Boxen mit NMP: 7x UFS910 (128MB), UFS912, 2x UFS913, AV700, AV7000, AV7500 (DVB-S/C/T), Edision Argus Pingulux, Vizyon820HD,
3x AX 4K HD51 (DVB-S/SX/C/T/T2), VU+DUO, VU+Solo4K (DVB-S/SX (FBC)/C/T/T2 (DUAL)), VU+Duo4K (DVB-S/SX (FBC)/C (FBC)),
VU+Ultimo4K (DVB-S/SX (FBC)/C (DUAL)), VU+Uno4KSE (DVB-S/SX (FBC)/C (FBC)), 2xVU+Zero4K (DVB-S/SX)

Benutzeravatar
satmonk
Registrierte Benutzer
Registrierte Benutzer
Beiträge: 12
Registriert: Do 4. Aug 2016, 19:34
Hat sich bedankt: 3 Mal
Danksagung erhalten: 2 Mal

Re: fehlende Software-Lüftersteuerung (Cuberevo / IPBox 9000)

#14

Beitrag von satmonk »

Naja, zumindest ist es möglich das Problem zu umgehen und das Frontpanel direkt über einen Befehl anzusteuern.

Habe noch einen Serial Log vom PKT gemacht und genau den Moment abgepasst bei dem sich der Lüfter einschaltet:

Code: Alles auswählen

PKT SVN-3503
fp_control: SW Version 1.04
Model: cuberevo
vBoxType: 12
Selected Model: CUBEREVO frontpanel control utility
init
configs: DISPLAY = 1, DISPLAYCUSTOM = 1, CUSTOM = %H:%M %a %d.%m   
, WAKEUPDECREMENT 300
Wo genau der Lüftertreiber beim PKT sitzt (wenn überhaupt einzeln, vielleicht ist dieser im Frontpanel Treiber integriert) konnte ich nicht ausfindig machen :-(
Aufgefallen ist mir die unterschiedliche vBoxType: (8 bei Neutrino / 12 bei PKT)

Benutzeravatar
BPanther
Administrator
Administrator
Beiträge: 11020
Registriert: Do 11. Jan 2007, 00:06
Wohnort: Berlin
Hat sich bedankt: 228 Mal
Danksagung erhalten: 369 Mal
Kontaktdaten:

Re: fehlende Software-Lüftersteuerung (Cuberevo / IPBox 9000)

#15

Beitrag von BPanther »

Der vBoxtype richtet sich nach der Anzahl der Definitionen in der global.h von fp_control, hat also von der Nummer her nicht wirklich was zu sagen. Insgesamt zeigt aber der Ausschnitt, daß die das auch nur einfach in die rcS verlegt haben und per fp_control steuern und keinen eigenen Treiber dafür nutzen.
MfG BPanther
KEIN SUPPORT PER PN -> Bitte das Forum nutzen und das Wiki lesen.


Bild Bild
Thx udog für das Bild.
TV: Sony Bravia KDL-46HX755, Sony Bravia KDL-40W4500 (old)
Boxen mit NMP: 7x UFS910 (128MB), UFS912, 2x UFS913, AV700, AV7000, AV7500 (DVB-S/C/T), Edision Argus Pingulux, Vizyon820HD,
3x AX 4K HD51 (DVB-S/SX/C/T/T2), VU+DUO, VU+Solo4K (DVB-S/SX (FBC)/C/T/T2 (DUAL)), VU+Duo4K (DVB-S/SX (FBC)/C (FBC)),
VU+Ultimo4K (DVB-S/SX (FBC)/C (DUAL)), VU+Uno4KSE (DVB-S/SX (FBC)/C (FBC)), 2xVU+Zero4K (DVB-S/SX)

Antworten

Zurück zu „Anregungen / Wünsche“