Sat <> IP

jockyw2001
Registrierte Benutzer
Registrierte Benutzer
Beiträge: 23
Registriert: Do 4. Aug 2016, 14:33

Re: Sat <> IP

#106

Beitrag von jockyw2001 » Sa 6. Aug 2016, 15:11

I could build vtunerc.ko (v1.4) and can insmod it. After insmodding I find following references to vtuner:

Code: Alles auswählen

ufs910:/# find * | grep vtun
proc/vtunerc0
sys/devices/virtual/vtuner
sys/devices/virtual/vtuner/vtunerc0
sys/devices/virtual/vtuner/vtunerc0/uevent
sys/devices/virtual/vtuner/vtunerc0/dev
sys/devices/virtual/vtuner/vtunerc0/suppress_bind
sys/devices/virtual/vtuner/vtunerc0/subsystem
sys/class/vtuner
sys/class/vtuner/vtunerc0
sys/module/vtunerc
sys/module/vtunerc/holders
sys/module/vtunerc/parameters
sys/module/vtunerc/parameters/debug
sys/module/vtunerc/parameters/tscheck
sys/module/vtunerc/parameters/devices
sys/module/vtunerc/parameters/adapter_nr
sys/module/vtunerc/version
sys/module/vtunerc/srcversion
sys/module/vtunerc/initstate
sys/module/vtunerc/refcnt
But no devices are created in /dev. Following devices should be created:

DVB:

/dev/dvb/adapterX/demux0
/dev/dvb/adapterX/dvr0
/dev/dvb/adapterX/frontend0 [registered later]

controlling:

/dev/vtunerX

where X is ordered by driver installation.

In order words, I need help :)

Why are there no devices created?

Benutzeravatar
mohousch
Registrierte Benutzer
Registrierte Benutzer
Beiträge: 928
Registriert: Di 18. Sep 2012, 20:21
Hat sich bedankt: 7 Mal
Danksagung erhalten: 16 Mal

Re: Sat <> IP

#107

Beitrag von mohousch » Sa 6. Aug 2016, 21:05

There is no Auto Script which create from Sys Devices the Devices nodes you need at Start a Script using mdev original mknod zo create staticlly the Device nodes.

Nhd2 can manage only 2 DVB Adapters

jockyw2001
Registrierte Benutzer
Registrierte Benutzer
Beiträge: 23
Registriert: Do 4. Aug 2016, 14:33

Re: Sat <> IP

#108

Beitrag von jockyw2001 » So 7. Aug 2016, 09:31

ThX mohousch mknod works. Is there a cdk script which I can update to pre-create the dev nodes in the tufsbox release? (EDIT1: I found the answer -> /sbin/MAKEDEV does the work).

EDIT2: Getting closer: driver and satip-client seem to work fine, but I have a neutrino zapit problem with adapter1. In the neutrino channelsearch/tuner gui the vtuner shows up as virtual tuner device (/dev/dvb/adapter1). In the neutrino channelsearch gui I deactivated the built-in tuner (/dev/dvb/adapter0) and then tried a channel search with vtuner, but after saving the selected satellite (Astra 19.2), neutrino hangs. I think because in neutrino zapit sourcecode adapter0 is hardcoded:

Code: Alles auswählen

# grep -ir adapter0 *
zapit/src/zapit.cpp:		int dmx = open("/dev/dvb/adapter0/demux0", O_RDWR );
zapit/src/zapit.cpp:			printf("%s: ERROR open /dev/dvb/adapter0/demux0 (%m)\n", __func__);
user@ubuntu:~/ufs910/mohousch-neutrino/ufs910/tdt/source/neutrinohd2/neutrinohd2.git/nhd2-exp/src$ grep -ir adapter1 *


It looks I must rebuild neutrino-HD2 with only vtuner.

Btw, here is how I currently test vtuner:

Code: Alles auswählen

killall -9 rcS
killall -9 neutrino

cd /var/tuxbox/satip
insmod vtunerc.ko devices=1 debug=0

mknod /dev/vtunerc0 c 266 0

mknod /dev/dvb/adapter1/frontend0 c 212 67
mknod /dev/dvb/adapter1/demux0 c 212 68
mknod /dev/dvb/adapter1/dvr0 c 212 69


sleep 1
mkdir -p /dev/dvb/adapter1
chmod a+rw /dev/vtunerc*
chmod a+rw /dev/dvb/adapter1/*

./satip-client -s 192.168.1.78 -t 0 -l 4

/usr/local/bin/neutrino
Let me know if you guys have any suggestions.

EDIT3: I got a bit further, but there is another problem: after restarting neutrino manually the network stops:

Code: Alles auswählen

initFrontend found 2 frontends
zapit: loadFrontendConfig
[video_cs.cpp]:cVideo
[video_cs.cpp]:SetVideoSystem - video_system=VIDEO_STD_1080P24
[audio_cs.cpp]:cAudio
dvb-ci.cpp:getInstance
dvb-ci.cpp:cDvbCi
zapit:loadZapitSettings
zapit:loadAudioMap
zapit: loadFrontendConfig
getServices:loadTransponders:
getServices:loadServices:
getservices:FindTransponder: going to parse dvb-s provider Astra 1KR/1L/1M/2C (1
9.2E) position 192
getservices:loadingmotorpositions...
[zapit] 1571 services loaded (1571)...
getservices:FindTransponder: going to parse dvb-s provider Astra 1KR/1L/1M/2C (1
9.2E) position 192
[zapit] duplicate transponder id 2dc700c000030085 freq 11719000
replacing 'Sky Sport News' (sid=0xf1): succeded.
replacing 'Sky Select 3' (sid=0x10f): succeded.
replacing 'Sky Bundesliga 3' (sid=0x110): succeded.
replacing 'Sky Sport 4' (sid=0x111): succeded.
replacing 'Sky Select 4' (sid=0x119): succeded.
replacing 'Sky Bundesliga 4' (sid=0x11a): succeded.
replacing 'Sky Sport 5' (sid=0x11b): succeded.
replacing 'Sky Select 5' (sid=0x123): succeded.
replacing 'Sky Bundesliga 5' (sid=0x124): succeded.
replacing 'Sky Sport 6' (sid=0x125): succeded.
replacing 'Sky Select 6' (sid=0x12d): succeded.
replacing 'Sky Bundesliga 6' (sid=0x12e): succeded.
replacing 'Sky Sport 7' (sid=0x12f): succeded.
[zapit] duplicate transponder id 2dee00c000110085 freq 11758000
replacing 'Sky Select 7' (sid=0x137): succeded.
replacing 'Sky Bundesliga 7' (sid=0x138): succeded.
replacing 'Sky Sport 8' (sid=0x139): succeded.
replacing 'Sky Select 8' (sid=0x141): succeded.
replacing 'Sky Bundesliga 8' (sid=0x142): succeded.
replacing 'Sky Sport 9' (sid=0x143): succeded.
replacing 'Sky Select 9' (sid=0x14b): succeded.
replacing 'Sky Bundesliga 9' (sid=0x14c): succeded.
replacing 'Sky Sport 10' (sid=0x14d): succeded.
replacing 'Sky Select Event B' (sid=0x14e): succeded.
[zapit] duplicate transponder id 2e1500c000020085 freq 11797000
replacing 'Sky Select 1' (sid=0xfb): succeded.
replacing 'Sky Bundesliga 10' (sid=0xfc): succeded.
replacing 'Sky Sport 11' (sid=0xfd): succeded.
replacing 'Sky Select Event A' (sid=0xfe): succeded.
replacing 'Sky Select 2' (sid=0x105): succeded.
replacing 'Sky Bundesliga 2' (sid=0x106): succeded.
replacing 'Sky Sport 3' (sid=0x107): succeded.
[zapit] duplicate transponder id 2f2600c000010085 freq 12070000
replacing 'Blue Movie 1' (sid=0x159): succeded.
replacing 'Blue Movie 2' (sid=0x163): succeded.
replacing 'Blue Movie 3' (sid=0x16d): succeded.
[zapit] duplicate transponder id 301000c0000c0085 freq 12304000
replacing 'Sky Sport News HD' (sid=0xf2): succeded.
replacing 'Sky Bundesliga HD 4' (sid=0x11f): succeded.
replacing 'Sky Sport HD 5' (sid=0x120): succeded.
prepare_channels: loadServices: success
reading /var/tuxbox/config/zapit/bouquets.xml
CBouquetManager::parseBouquetsXml: reading bouquets
CBouquetManager::parseBouquetsXml: found 117 bouquets
reading /var/tuxbox/config/zapit/ubouquets.xml
CBouquetManager::parseBouquetsXml: reading bouquets
CBouquetManager::parseBouquetsXml: found 132 bouquets
/tmp/currentservices.xml: No such file or directory
zapit:leaveStandby
[zapit] sdt_thread: starting... tid 655
[zapit] sdt monitor started
Open /dev/dvb/adapter1/video0 failed
zapit: zapto channel id 40100012856 nvod 0
[pmt] stop update filter
[zapit] stopPlayBack: standby 0 forced 0
zapit:saveZapitSettings
getFrontend: fe(0,0): (NOTCONNECTED) tuned:0 (locked:0) fe_freq: 0 fe_TP: 0 - ch
an_freq: 11582 chan_TP: 2d3e00c004010001 sat-position: 192 sat-name:Astra 1KR/1L
/1M/2C (19.2E) input-type:1
getFrontend: fe(1,0): (SINGLE) tuned:0 (locked:0) fe_freq: 0 fe_TP: 0 - chan_fre
q: 11582 chan_TP: 2d3e00c004010001 sat-position: 192 sat-name:Astra 1KR/1L/1M/2C
 (19.2E) input-type:1
getFrontend Selected fe: (1,0)
initTuner Frontend (1,0)
CFrontend::Open /dev/dvb/adapter1/frontend0 vTuner proxyFE DVB-S2
Frontend (1,0) as slave: no
CFrontend::secSetVoltage: fe(1,0) voltage 13
CFrontend::setDiseqcType: NO_DISEQC
zapit zap to BR Nord HD(40100012856) fe(1,0)
CFrontend::setInput: fe(1,0) SatellitePosition 0 -> 192
CFrontend::setLnbOffsets: fe(1,0) setLnbOffsets 9750000/10600000/11700000
CFrontend::tuneChannel: fe(1,0) tpid 2d3e00c004010001
CFrontend::secSetVoltage: fe(1,0) voltage 18
CFrontend::setParameters: fe(1,0) freq= 1832000 (offset= 9750000) fec= 20
CFrontend::setFrontend: fe(1,0) DEMOD: FEC 2/3 system DVB-S2 modulation 8PSK
cFrontend::getEvent: fe(1,0) max timeout: 9000
poll has event after: 0 msec (min 0 max 0)
poll has event after: 47 msec (min 0 max 47)
cFrontend::getEvent fe(1,0) FE_HAS_LOCK: freq 1832000
CFrontend::setParameters: fe(1,0) tuned
parse_channel_pat_pmt looking up pids for channel_id (40100012856)
[pmt]parse_pmt: parsing pmt pid 0x145A
cDemux::Open /dev/dvb/adapter1/demux0 type:DMX_PSI_CHANNEL BufferSize:1024 sourc
e(0)
Open: setting /dev/dvb/adapter1/demux0 to source 0
DMX_SET_SOURCE: Invalid argument
[dmx_cs.cpp]:sectionFilter dmx(0) type=DMX_PSI_CHANNEL Pid=0x145a Len=5 Timeout=
1500
cDemux::Read: Connection timed out
[pmt]parse_pmt: dmx read failed
cDemux::~cDemux(0)
[dmx_cs.cpp]:Close type=DMX_PSI_CHANNEL Pid 0x145a
[zapit] pmt parsing failed
parse_pat
cDemux::Open /dev/dvb/adapter1/demux0 type:DMX_PSI_CHANNEL BufferSize:1024 sourc
e(0)
Open: setting /dev/dvb/adapter1/demux0 to source 0
DMX_SET_SOURCE: Invalid argument
[dmx_cs.cpp]:sectionFilter dmx(0) type=DMX_PSI_CHANNEL Pid=0x0 Len=5 Timeout=200
0
cDemux::Read: Connection timed out
parse_pat: dmx read failed
cDemux::~cDemux(0)
[dmx_cs.cpp]:Close type=DMX_PSI_CHANNEL Pid 0x0
pat parsing failed
[zapit] trying again
parse_channel_pat_pmt looking up pids for channel_id (40100012856)
[pmt]parse_pmt: parsing pmt pid 0x145A
cDemux::Open /dev/dvb/adapter1/demux0 type:DMX_PSI_CHANNEL BufferSize:1024 sourc
e(0)
Open: setting /dev/dvb/adapter1/demux0 to source 0
DMX_SET_SOURCE: Invalid argument
[dmx_cs.cpp]:sectionFilter dmx(0) type=DMX_PSI_CHANNEL Pid=0x145a Len=5 Timeout=
1500
cDemux::Read: Connection timed out
[pmt]parse_pmt: dmx read failed
cDemux::~cDemux(0)
[dmx_cs.cpp]:Close type=DMX_PSI_CHANNEL Pid 0x145a
[zapit] pmt parsing failed
parse_pat
cDemux::Open /dev/dvb/adapter1/demux0 type:DMX_PSI_CHANNEL BufferSize:1024 sourc
e(0)
Open: setting /dev/dvb/adapter1/demux0 to source 0
DMX_SET_SOURCE: Invalid argument
[dmx_cs.cpp]:sectionFilter dmx(0) type=DMX_PSI_CHANNEL Pid=0x0 Len=5 Timeout=200
0
cDemux::Read: Connection timed out
parse_pat: dmx read failed
cDemux::~cDemux(0)
[dmx_cs.cpp]:Close type=DMX_PSI_CHANNEL Pid 0x0
pat parsing failed
zapTo_ChannelID: zapit failed, chid 40100012856
dvbsub_init: starting... tid 648
[audio_cs.cpp]:setVolume volume: 15
[video_cs.cpp]:setAspectRatio
[video_cs.cpp] setAspectRatio (aspect=1 format=3) set 16:9 bestfit
[video_cs.cpp]:SetWideScreen - mode=auto
[video_cs.cpp]:SetSyncMode
[video_cs.cpp]:SetSyncMode - mode=AVSYNC_ENABLED
[video_cs.cpp]:SetSyncMode - set master clock = video
[audio_cs.cpp]:SetHdmiDD downmix
[audio_cs.cpp]:setHwAC3Delay - delay=0
[audio_cs.cpp]:setHwPCMDelay - delay=0
cDemux::Open /dev/dvb/adapter1/demux0 type:DMX_PES_CHANNEL BufferSize:65536 sour
ce(0)
Open: setting /dev/dvb/adapter1/demux0 to source 0
DMX_SET_SOURCE: Invalid argument
[dmx_cs.cpp]:Stop dmx(0) type=DMX_PES_CHANNEL Pid 0x0
[yhttpd] Webserver nhttpd/3.3.2 (yhttpd_core/1.3.1) tid 659
streamts_main_thread: Starting STREAM thread keeper, tid 660
sectionsd_main_thread: startup, tid 661
timerd_main_thread: startup, tid 658
CTimerManager::Init: wakeup from standby: no
CTimerManager::Init: timermanager created
[dvbsub @ 0xb32b40] Invalid DVB subtitles stream extradata!
[sectionsd] Caching max 50000 events
[sectionsd] Caching 14 days
[sectionsd] Caching 360 hours Extended Text
[sectionsd] Events are old 60min after their end time
/var/tuxbox/config/zapit/epgfilter.xml: No such file or directory
dvb-ci.cpp:getInstance
CNetworkConfig::getInstance: Instance created
CNetworkSettings::getInstance: Instance created
CNetworkConfig::readConfig: eth0
CNetworkConfig::init_vars
cDemux::Open /dev/dvb/adapter1/demux0 type:DMX_PSI_CHANNEL BufferSize:524288 sou
rce(0)
Open: setting /dev/dvb/adapter1/demux0 to source 0
DMX_SET_SOURCE: Invalid argument
[dmx_cs.cpp]:sectionFilter dmx(0) type=DMX_PSI_CHANNEL Pid=0x12 Len=1 Timeout=20
00
cDemux::Open /dev/dvb/adapter1/demux0 type:DMX_PSI_CHANNEL BufferSize:327680 sou
rce(0)
Open: setting /dev/dvb/adapter1/demux0 to source 0
DMX_SET_SOURCE: Invalid argument
[dmx_cs.cpp]:sectionFilter dmx(0) type=DMX_PSI_CHANNEL Pid=0xf02 Len=1 Timeout=0
cDemux::Open /dev/dvb/adapter1/demux0 type:DMX_PSI_CHANNEL BufferSize:3072000 so
urce(0)
Open: setting /dev/dvb/adapter1/demux0 to source 0
cDemux::Open /dev/dvb/adapter1/demux0 type:DMX_PSI_CHANNEL BufferSize:3072000 so
urce(0)
Open: setting /dev/dvb/adapter1/demux0 to source 0
CNetworkConfig: eth0 loaded, wireless no
DMX_SET_SOURCE: Invalid argument
DMX_SET_SOURCE: Invalid argument
CNetworkConfig::stopNetwork
[dmx_cs.cpp]:sectionFilter dmx(0) type=DMX_PSI_CHANNEL Pid=0x39 Len=1 Timeout=0
Why does the network stop ? Is it stopping the network because of this: DMX_SET_SOURCE: Invalid argument ?

Benutzeravatar
mohousch
Registrierte Benutzer
Registrierte Benutzer
Beiträge: 928
Registriert: Di 18. Sep 2012, 20:21
Hat sich bedankt: 7 Mal
Danksagung erhalten: 16 Mal

Re: Sat <> IP

#109

Beitrag von mohousch » So 7. Aug 2016, 16:11

Neutrino look for the First Free Tuner you can in Tuner Setup Set up the one as deactivate so neutrino will prefer the virtuell Tuner

jockyw2001
Registrierte Benutzer
Registrierte Benutzer
Beiträge: 23
Registriert: Do 4. Aug 2016, 14:33

Re: Sat <> IP

#110

Beitrag von jockyw2001 » So 7. Aug 2016, 17:10

mohousch hat geschrieben:Neutrino look for the First Free Tuner you can in Tuner Setup Set up the one as deactivate so neutrino will prefer the virtuell Tuner
It looks Neutrino finds the correct tuner (see previous post last code snippet). The problem seems to be my satipclient cannot allocate /dev/vtunerc0 :

Code: Alles auswählen

ufs910:~/tuxbox/satip# ./satipclient -l4
[645 option.cpp          :  44][dump                     ]       debug: [0] tuner type : satip_client, ip : 192.168.1.96, fe_type : 0
[645 option.cpp          :  31][optParser                ]       debug: 1 Satip configuration loaded..
[645 manager.cpp         :  32][sessionManager           ]       debug: Create resource manager.
[645 manager.cpp         :  58][satipStart               ]       debug: try connect : [0] type : satip_client, ip : 192.168.1.96, fe_type : 0
[645 session.cpp         :  45][satipSession             ]       debug: Create SESSION.(host : 192.168.1.96, rtsp_port : 554, fe_type : 0
[645 vtuner.cpp          :  43][satipVtuner              ]       debug: Create SATIP VTUNER.
[645 vtuner.cpp          :  94][openVtuner               ]       debug: Allocate vtuner failed!
[645 vtuner.cpp          :  48][satipVtuner              ]       error: vtuner control failed
EDIT1: I solved the vtunerc allocation problem. Now getting following debug output from satipclient:

Code: Alles auswählen

ufs910:~/tuxbox/satip# ./satipclient -l4
[644 option.cpp          :  44][dump                     ]       debug: [0] tuner type : satip_client, ip : 192.168.1.96, fe_type : 0
[644 option.cpp          :  31][optParser                ]       debug: 1 Satip configuration loaded..
[644 manager.cpp         :  32][sessionManager           ]       debug: Create resource manager.
[644 manager.cpp         :  58][satipStart               ]       debug: try connect : [0] type : satip_client, ip : 192.168.1.96, fe_type : 0
[644 session.cpp         :  45][satipSession             ]       debug: Create SESSION.(host : 192.168.1.96, rtsp_port : 554, fe_type : 0
[644 vtuner.cpp          :  43][satipVtuner              ]       debug: Create SATIP VTUNER.
[644 vtuner.cpp          :  77][AllocateVtuner           ]       debug: Allocate vtuner /dev/vtunerc0
[644 vtuner.cpp          : 200][openVtuner               ]       error: VTUNER_SET_HAS_OUTPUTS error
[644 vtuner.cpp          : 203][openVtuner               ]       debug: Vtuner initialize OK!
[644 rtp.cpp             :  51][satipRTP                 ]       debug: Create RTP.
[644 rtp.cpp             : 129][openRTP                  ]        info: RTP PORT : 46512, RTCP PORT : 46513
[644 rtsp.cpp            :  56][satipRTSP                ]       debug: Create RTSP. (host : 192.168.1.96, port : 554, rtp_port : 46512)
[644 timer.cpp           :  51][create                   ]       debug: satipTimer::create timer reset connect
[644 timer.cpp           :  45][dump                     ]       debug: TIMER DUMP : 1539415395 (inactive)
[644 timer.cpp           :  57][create                   ]       debug: satipTimer::create end.
[644 timer.cpp           :  51][create                   ]       debug: satipTimer::create timer keep alive message
[644 timer.cpp           :  45][dump                     ]       debug: TIMER DUMP : 1539415394 (inactive)
[644 timer.cpp           :  45][dump                     ]       debug: TIMER DUMP : 1539415394 (inactive)
[644 timer.cpp           :  45][dump                     ]       debug: TIMER DUMP : 50049483 (inactive)
[644 timer.cpp           :  57][create                   ]       debug: satipTimer::create end.
[644 rtsp.cpp            :  75][resetConnect             ]       debug: resetConnect
[644 rtsp.cpp            : 840][stopTimerResetConnect    ]       debug: stopTimerResetConnect
[644 rtsp.cpp            : 852][stopTimerKeepAliveMessage]       debug: stopTimerKeepAliveMessage
[644 manager.cpp         :  80][satipSessionCreate       ]       debug: Create satip session ok (192.168.1.96 , 0)
[644 manager.cpp         :  84][satipSessionCreate       ]       debug: Satip session start (192.168.1.96 , 0)
[644 rtsp.cpp            : 631][handleRTSPStatus         ]       debug: RTSP STATUS : RTSP_STATUS_CONFIG_WAITING
[644 rtp.cpp             : 303][rtpDump                  ]       debug: RTP LOOP START
[644 rtsp.cpp            : 631][handleRTSPStatus         ]       debug: RTSP STATUS : RTSP_STATUS_CONFIG_WAITING
[644 rtsp.cpp            : 631][handleRTSPStatus         ]       debug: RTSP STATUS : RTSP_STATUS_CONFIG_WAITING
...
Still the same problem: neutrino stops network and satipclient is only waiting for minisatip it seems, because as long as network still working satipclient shows:

Code: Alles auswählen

debug: RTSP STATUS : RTSP_STATUS_CONFIG_WAITING
Tomorrow another day :)

jockyw2001
Registrierte Benutzer
Registrierte Benutzer
Beiträge: 23
Registriert: Do 4. Aug 2016, 14:33

Re: Sat <> IP

#111

Beitrag von jockyw2001 » Di 9. Aug 2016, 00:33

Status update: no video yet, but all the rest is working: epg, videotext, soundtracks etc. I'm getting this error and that's prolly why there is no video:

Code: Alles auswählen

Open: setting /dev/dvb/adapter0/demux0 to source 0
DMX_SET_SOURCE: Invalid argument
Tomorrow another day :)

jockyw2001
Registrierte Benutzer
Registrierte Benutzer
Beiträge: 23
Registriert: Do 4. Aug 2016, 14:33

Re: Sat <> IP

#112

Beitrag von jockyw2001 » Mi 10. Aug 2016, 00:29

Today I found that streaming off the webinterface (VLC stream) works wonderful, no stuttering whatsoever. In VLC player I could see all the elementary video, audio and subtitle streams are present. So it means the virtual tuner device and the satip client work fine in neutrino-hd2. However, still no video shown on TV. I attach a full neutrino console log and hope you guys can see what is wrong. I suspect the problem is this:

Code: Alles auswählen

Open /dev/dvb/adapter0/video0 failed
Is that also shown when stb is working with built-in tuner?
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.

Benutzeravatar
mohousch
Registrierte Benutzer
Registrierte Benutzer
Beiträge: 928
Registriert: Di 18. Sep 2012, 20:21
Hat sich bedankt: 7 Mal
Danksagung erhalten: 16 Mal

Re: Sat <> IP

#113

Beitrag von mohousch » Mi 10. Aug 2016, 01:28

Yes
I thought the vtuner is referred under dvb Adapter 1 how Do you linken all dvb Devices to Adapter 0? Elsewhere vtuner dont provide Video 0 and audio0 (i think from your First log)

EDIT: can you Post Patches i will look tomorow how to link stream from Adapter1/demux0 to Adapter0/video0 e.g audio0

jockyw2001
Registrierte Benutzer
Registrierte Benutzer
Beiträge: 23
Registriert: Do 4. Aug 2016, 14:33

Re: Sat <> IP

#114

Beitrag von jockyw2001 » Mi 10. Aug 2016, 10:07

mohousch hat geschrieben:Yes
I thought the vtuner is referred under dvb Adapter 1 how Do you linken all dvb Devices to Adapter 0? Elsewhere vtuner dont provide Video 0 and audio0 (i think from your First log)
I disabled the built-in tuner in rcS so at the moment I only use adapter0 with vtuner's dvr0, demux0 and frontend0. These are the modifications I made in rcS so that I can test nicely:

Code: Alles auswählen

# JockyW: disable ufs910 tuner so that we can use adapter0. Enable in order to use adapter1 
#   insmod $MODDIR/cx24116.ko
...
# JockyW: configure eth0 now otherwise vpn access doesn't work ...   
   ifconfig eth0 192.168.1.71 netmask 255.255.255.0 broadcast 192.168.1.255

   /etc/init.d/portmap start
#   /etc/init.d/vsftpd start
   /usr/sbin/inetd

   #timefix
   date -s "200901011200"

   stfbcontrol a 255

   echo "LOADING neutrino" > /dev/vfd
   echo "LOADING neutrino"

#   until false
#   do
      echo "starting neutrino ->"
# JockyW: we have to manually bring eth0 up, stupidly this is done in neutrino sigh ...
	  /sbin/ifup eth0
	  
	  sleep 1
      insmod /var/tuxbox/satip/vtunerc.ko devices=1 debug=0
      mknod /dev/vtunerc0 c 266 0

# JockyW: adapter1 is used when built-in tuner is enabled (see above)
      mkdir -p /dev/dvb/adapter1
      mknod /dev/dvb/adapter1/frontend0 c 212 67
      mknod /dev/dvb/adapter1/demux0 c 212 68
      mknod /dev/dvb/adapter1/dvr0 c 212 69

      sleep 1
      chmod a+rw /dev/vtunerc*
      chmod a+rw /dev/dvb/adapter1/*
      sleep 1
# JockyW this satip client does not work (yet): /var/tuxbox/satip/satip-client -s 192.168.1.96 -t 0 -l 4
# JockyW this OE-Alliance satip client does not work (yet): /var/tuxbox/satip/satipclient -l4
# JockyW: this satip client works (but only for SD it seems)
      /var/tuxbox/satip/satip -h 192.168.1.96
      sleep 1 

#      /usr/local/bin/neutrino
#      rtv=$?
#      echo "neutrino ended <- RTV: " $rtv
#      case "$rtv" in
#		0) echo "0"
#		   echo "SHUTDOWN"
#		   init 0;;
#		1) echo "1"
#		   echo "REBOOT"
#		   init 6;;
#		*) echo "*"
#		   echo "ERROR"
#		   init 6;;
#     esac
#   done
fi

#never reached
#echo "REBOOT UFS910" > /dev/vfd
#echo "REBOOT UFS910"
#init 6
EDIT: can you Post Patches i will look tomorow how to link stream from Adapter1/demux0 to Adapter0/video0 e.g audio0
Do you have a ufs910 to test with, I can then also post a dump of mtd5 (full image w/o bl == miniFLASH.img)? Also you need a satip server. My satip server is a self-built minisatip server running on my atevio7500. I will post everything on my google drive in the next hours.

Benutzeravatar
mohousch
Registrierte Benutzer
Registrierte Benutzer
Beiträge: 928
Registriert: Di 18. Sep 2012, 20:21
Hat sich bedankt: 7 Mal
Danksagung erhalten: 16 Mal

Re: Sat <> IP

#115

Beitrag von mohousch » Mi 10. Aug 2016, 11:26

I have gigablue800se (mipsel) and Cuberevo 3000hd (sh4) with out Tuner driver.
ok for just testing you can use Adapter0

Can Not test at the Moment :-(

jockyw2001
Registrierte Benutzer
Registrierte Benutzer
Beiträge: 23
Registriert: Do 4. Aug 2016, 14:33

Re: Sat <> IP

#116

Beitrag von jockyw2001 » Do 11. Aug 2016, 01:15

Still no video with tv channels, but I can record and play the recorded movies with audio & video now !

To achieve this I had to add a few symlinks in rcS:

Code: Alles auswählen

#   until false
#   do
      echo "starting neutrino ->"

# JockyW: we have to manually bring eth0 up, stupidly this is done in neuttrino sigh ...
          /sbin/ifup eth0

      sleep 1

# JockyW: adapter1 is used when built-in tuner is enabled (see above)
      mkdir -p /dev/dvb/adapter1
      mknod /dev/dvb/adapter1/frontend0 c 212 67
      mknod /dev/dvb/adapter1/demux0 c 212 68
      mknod /dev/dvb/adapter1/dvr0 c 212 69
      mknod /dev/dvb/adapter1/audio0 c 212 65
      mknod /dev/dvb/adapter1/video0 c 212 64
      mknod /dev/dvb/adapter1/ca0 c 212 70
      mknod /dev/dvb/adapter1/ci0 c 212 73
#      ln -s /dev/dvb/adapter0/video0 /dev/dvb/adapter1/video0
#      ln -s /dev/dvb/adapter0/audio0 /dev/dvb/adapter1/audio0

      sleep 1
      chmod a+rw /dev/vtunerc*
      chmod a+rw /dev/dvb/adapter1/*

# JockyW: these symlinks allow playing video files with audio & video !
      rm /dev/dvb/adapter0/video0
      ln -s /dev/dvb/adapter1/video0 /dev/dvb/adapter0/video0
      rm /dev/dvb/adapter0/audio0
      ln -s /dev/dvb/adapter1/audio0 /dev/dvb/adapter0/audio0
      chmod a+rw /dev/dvb/adapter0/*
      mount -t vfat /dev/sda1 /media/hdd

      sleep 1
# JockyW this satip client does not work (yet): /var/tuxbox/satip/satip-client -s 192.168.1.96 -t 0 -l 4
# JockyW this OE-Alliance satip client does not work (yet): /var/tuxbox/satip/satipclient -l4
# JockyW: this satip client works (but only for SD it seems)
      /var/tuxbox/satip/satip -h 192.168.1.96
      sleep 1

#      /usr/local/bin/neutrino



These are the specific lines required for being able to play the recordings:

Code: Alles auswählen

      ln -s /dev/dvb/adapter1/video0 /dev/dvb/adapter0/video0
      ln -s /dev/dvb/adapter1/audio0 /dev/dvb/adapter0/audio0
I don't understand why I don't get audio and video on tv channels, although I created nodes in the device tree for adapter1. At least Neutrino opens audio and video devices now without errors:

Code: Alles auswählen

zapit:leaveStandby
cVideo::Open /dev/dvb/adapter1/video0
[video_cs.cpp]:setSource - source=VIDEO_SOURCE_DEMUX
cAudio::Open /dev/dvb/adapter1/audio0
[audio_cs.cpp]:setSource - source=AUDIO_SOURCE_DEMUX
zapit: zapto channel id 44100012ee3 nvod 0
[pmt] stop update filter
[zapit] stopPlayBack: standby 0 forced 0
zapit:saveZapitSettings
getFrontend: fe(0,0): (SINGLE) tuned:0 (locked:0) fe_freq: 0 fe_TP: 0 - chan_freq: 12187 chan_TP: 2f9b00c004410001 sat-position: 192 sat-name:Astra 1KR/1L/1M/2C (19.2E) input-type:1
getFrontend Selected fe: (0,0)
initTuner Frontend (0,0)
CFrontend::Open /dev/dvb/adapter0/frontend0 vTuner proxyFE DVB-S2
If you have any suggestions let me know :)

jockyw2001
Registrierte Benutzer
Registrierte Benutzer
Beiträge: 23
Registriert: Do 4. Aug 2016, 14:33

Re: Sat <> IP

#117

Beitrag von jockyw2001 » Do 11. Aug 2016, 09:59

The attached package includes vtuner module (for kernel 2.6.32.61_stm24_0217), satip client and minisatip for sh4 boxes.

I run minisatip on a dual-tuner av7500 and have reserved tuner1 for minisatip. The cmdline to start it is then:

Code: Alles auswählen

minisatip -e 1:1 --dmx-source 1:1 -x 8081 -l
I run vtuner and satip client on my ufs910 and have a preconfigured test startup script rcS which assumes the files are stored in /var/tuxbox/satip

If you don't want to modify rcS, you can run the included loadmod.sh (also assumes all files are stored in /var/tuxbox/satip

Code: Alles auswählen

killall -9 rcS
killall -9 neutrino
cd /var/tuxbox/satip
./loadmod.sh
neutrino
Have fun and lets turn this into something usable !
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.

Benutzeravatar
mohousch
Registrierte Benutzer
Registrierte Benutzer
Beiträge: 928
Registriert: Di 18. Sep 2012, 20:21
Hat sich bedankt: 7 Mal
Danksagung erhalten: 16 Mal

Re: Sat <> IP

#118

Beitrag von mohousch » Do 11. Aug 2016, 14:13

Playing File is not the Same as from demux some changes musst be done in zapit e.g libdvbapi to link the TS from demux to Output device

jockyw2001
Registrierte Benutzer
Registrierte Benutzer
Beiträge: 23
Registriert: Do 4. Aug 2016, 14:33

Re: Sat <> IP

#119

Beitrag von jockyw2001 » Do 11. Aug 2016, 14:31

I suspect the no video problem is because of this failing ioctl call as can be seen in the neutrino console log many times:

Code: Alles auswählen

Open: setting /dev/dvb/adapter0/demux0 to source 0
DMX_SET_SOURCE: Invalid argument
nhd2-exp/src/zapit/include/linux/dvb/dmx.h:178:#define DMX_SET_SOURCE _IOW('o', 49, dmx_source_t)
nhd2-exp/lib/libdvbapi/dmx_cs.cpp:117: if (ioctl(demux_fd, DMX_SET_SOURCE, &n) < 0)
nhd2-exp/lib/libdvbapi/dmx_cs.cpp:119: perror("DMX_SET_SOURCE");

I think I need to patch this in the vtunerc module code somehow. But first I will patch dmx_cs.cpp to see if it makes a difference.

EDIT: I patched dmx_cs.cpp but unfortunately no video yet :(

Benutzeravatar
mohousch
Registrierte Benutzer
Registrierte Benutzer
Beiträge: 928
Registriert: Di 18. Sep 2012, 20:21
Hat sich bedankt: 7 Mal
Danksagung erhalten: 16 Mal

Re: Sat <> IP

#120

Beitrag von mohousch » Do 11. Aug 2016, 19:13

no this Headers Files are needed to buhlt for coolstream platform
stream Routing is done in libdvbapi and how the vtuner driver do this
take a look at the enigma2 Sourcecode links

Dont give up ;-P

Antworten

Zurück zu „NHD2 - Allgemeines“